An update for our Alpha 5 Ecosystem release of Eco: climate sim, new biomes, dynamic plants!



  • Similar issue here. I get stuck at 38%.



  • Yup. 38% on the local server, stuck on 40% on the SLG server.



  • Looks like it might just need a really long time to load, i have let it sit and its up to 45% now



  • Output log.

    Initialize engine version: 5.4.2f2 (b7e030c65c9b)
    GfxDevice: creating device client; threaded=1
    Direct3D:
        Version:  Direct3D 11.0 [level 11.0]
        Renderer: NVIDIA GeForce GTS 450 (ID=0xdc4)
        Vendor:   NVIDIA
        VRAM:     979 MB
    Begin MonoManager ReloadAssembly
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\Assembly-CSharp.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.UI.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\SampleClassLibrary.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\SampleClassLibrary.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\Eco.Shared.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\Eco.Shared.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\ICSharpCode.SharpZipLib.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\ICSharpCode.SharpZipLib.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\LZ4.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\LZ4.dll into Unity Child Domain
    - Completed reload, in  0.042 seconds
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Core.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\System.dll (this message is harmless)
    desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
    <RI> Initializing input.
    
    <RI> Input initialized.
    
    <RI> Initialized touch support.
    
    UnloadTime: 0.951092 ms
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Xml.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Configuration.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\Mono.Security.dll (this message is harmless)
    NullReferenceException: Object reference not set to an instance of an object
      at NetworkManager.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at InputManager.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    GfxDevice: creating device client; threaded=1
    GfxDevice: creating device client; threaded=1
    GfxDevice: creating device client; threaded=1
    The referenced script on this Behaviour (Game Object 'DragZone') is missing!
    
    (Filename:  Line: 1656)
    
    The referenced script on this Behaviour (Game Object 'Laws') is missing!
    
    (Filename:  Line: 1656)
    
    The referenced script on this Behaviour (Game Object 'Laws') is missing!
    
    (Filename:  Line: 1656)
    
    WARNING: Shader Unsupported: 'Triplanar/Masked Triplanar Pollutable' - Pass 'FORWARD' has no fragment shader
    WARNING: Shader Unsupported: 'Triplanar/Masked Triplanar Pollutable' - Pass 'FORWARD_DELTA' has no vertex shader
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at BowController.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    

    It goes on like this.



  • Now I'm stuck "loading objects".



  • go to the escape menu and tweak the view distance slightly



  • that fixed it, loaded right up when i did that



  • Tried it. Still "loading objects".



  • loading objects - try restarting the client



  • Have done, several times.



  • I can connect to my private server, but not SLG's test server.



  • OK, got it in the end. Looking good thus far.



  • E harvest animals is not working either



  • Crash or down for update ?



  • hey guys. ive been puttering around in your test server, and noticed a few things.

    well so far ive just walked around and built a hut. put both the workbench and research table inside, but both tables dont seem to recognize materials put inside. however with the workbench im somehow able to create stairs without having boards in stock.
    looking forward to tomorrows real release. thanks a ton for this great game though. 100 points to strangeloopgames



  • oh forgot to also mention. i cant seem to turn the sound on. i move the sliders up then hit esc and they reset back to 0 sound.



  • Ohhh I bought it and setup a server just in time for a big update? SWEET this game is so cool I am thinking of buying copies for all my nieces and nephews soon as its done



  • Another issue, looks like besides the music / SFX going back to 0, the resolution that you set in the launcher doesn't stick to the config file either.



  • hey, just hopped on the slg server to try a few things:

    • chests cant be locked/unlocked anymore?
    • chests dont need a room anymore?
    • chests being "public storage" even on claimed property? is it unlocked or locked - i cant tell
    • no weight display in the backpack anymore? x/20
    • crafting/chest ui-windows dont dissapear when you move to far away? it's not only the window, also the access-range. i can manage my chest from far away as long as i leave the window open
    • having logging yield and chopping pieces big enough that would give you more than 5 logs at once results in "you can only carry 5 logs". this would potentially brick the log pickup entirely if the yield skill is high enough.
    • tooltips in the skills-ui no longer show the actual increase you get, only vague "log gain is increased / reduces calorie usage" - no flat values or percentages (please give us this information back)
    • scythe harvest results in the plant dissapearing from the world and the player not getting anything in the inventory (handpicking fern and berries is the only way to get food right now)

    edit:

    • controls/cursor keeps going back into "player mode" while you are in "interface mode" this is particularly disturbing when you are doing crafts and clicking in the interface when you suddenly move around with your player/camera
    • neither workbench nor research table recognize the items in storage (i tried both public and private)
    • the "split stack" window is non-responsive. you can move the slider but you cant click "ok" or move the window itself.
    • wooden stairs are indicated with 0 board cost. you can craft 1 at a time, with a larger order it says "you do not have the items needed to create this order"

    and because of those bugs, this is as far as i can progress with this version (im aware that it's not the real alpha 5)

    hope you guys can unbrick the game soon so we can enjoy a playable alpha 5 version

    because besides the bugs that make this version -currently- unplayable i enjoyed the new features, graphics and content alot and am looking forward to see a functioning alpha 5!

    my favourite new feature? not having your workbenches/stores(i assume) blocked for removal by other players (after 24 hrs) anymore.Screenshot_506.png



  • @Will-Eco said:

    We’ve been working hard getting the Ecosystem update ready for Eco Alpha 5 and looking forward to getting feedback from our early backers. We’ve decided to give it a few more weeks of polish and bug-fixing before we send it out, so we’re moving the Alpha 5 date to Oct 24th.

    After playing on the test server last night for a few hours, A5 is very much broken still. Are we looking at another few weeks before A5 comes out??


Log in to reply