An update for our Alpha 5 Ecosystem release of Eco: climate sim, new biomes, dynamic plants!



  • @Metachronism Great, thanks!



  • @Metachronism loading world hangs at 40% wont go any further, and redownloaded client after you said something about the tables all looking like chests.



  • Similar issue here. I get stuck at 38%.



  • Yup. 38% on the local server, stuck on 40% on the SLG server.



  • Looks like it might just need a really long time to load, i have let it sit and its up to 45% now



  • Output log.

    Initialize engine version: 5.4.2f2 (b7e030c65c9b)
    GfxDevice: creating device client; threaded=1
    Direct3D:
        Version:  Direct3D 11.0 [level 11.0]
        Renderer: NVIDIA GeForce GTS 450 (ID=0xdc4)
        Vendor:   NVIDIA
        VRAM:     979 MB
    Begin MonoManager ReloadAssembly
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\Assembly-CSharp.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.UI.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\SampleClassLibrary.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\SampleClassLibrary.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\Eco.Shared.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\Eco.Shared.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\ICSharpCode.SharpZipLib.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\ICSharpCode.SharpZipLib.dll into Unity Child Domain
    Platform assembly: C:\Eco\Eco_Data\Managed\LZ4.dll (this message is harmless)
    Loading C:\Eco\Eco_Data\Managed\LZ4.dll into Unity Child Domain
    - Completed reload, in  0.042 seconds
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Core.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\System.dll (this message is harmless)
    desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
    <RI> Initializing input.
    
    <RI> Input initialized.
    
    <RI> Initialized touch support.
    
    UnloadTime: 0.951092 ms
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Xml.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\System.Configuration.dll (this message is harmless)
    Platform assembly: C:\Eco\Eco_Data\Managed\Mono.Security.dll (this message is harmless)
    NullReferenceException: Object reference not set to an instance of an object
      at NetworkManager.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at InputManager.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    GfxDevice: creating device client; threaded=1
    GfxDevice: creating device client; threaded=1
    GfxDevice: creating device client; threaded=1
    The referenced script on this Behaviour (Game Object 'DragZone') is missing!
    
    (Filename:  Line: 1656)
    
    The referenced script on this Behaviour (Game Object 'Laws') is missing!
    
    (Filename:  Line: 1656)
    
    The referenced script on this Behaviour (Game Object 'Laws') is missing!
    
    (Filename:  Line: 1656)
    
    WARNING: Shader Unsupported: 'Triplanar/Masked Triplanar Pollutable' - Pass 'FORWARD' has no fragment shader
    WARNING: Shader Unsupported: 'Triplanar/Masked Triplanar Pollutable' - Pass 'FORWARD_DELTA' has no vertex shader
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at BowController.Update () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    
    NullReferenceException: Object reference not set to an instance of an object
      at Rotate.FixedUpdate () [0x00000] in <filename unknown>:0 
    
    (Filename:  Line: -1)
    

    It goes on like this.



  • Now I'm stuck "loading objects".



  • go to the escape menu and tweak the view distance slightly



  • that fixed it, loaded right up when i did that



  • Tried it. Still "loading objects".



  • loading objects - try restarting the client



  • Have done, several times.



  • I can connect to my private server, but not SLG's test server.



  • OK, got it in the end. Looking good thus far.



  • E harvest animals is not working either



  • Crash or down for update ?



  • hey guys. ive been puttering around in your test server, and noticed a few things.

    well so far ive just walked around and built a hut. put both the workbench and research table inside, but both tables dont seem to recognize materials put inside. however with the workbench im somehow able to create stairs without having boards in stock.
    looking forward to tomorrows real release. thanks a ton for this great game though. 100 points to strangeloopgames



  • oh forgot to also mention. i cant seem to turn the sound on. i move the sliders up then hit esc and they reset back to 0 sound.



  • Ohhh I bought it and setup a server just in time for a big update? SWEET this game is so cool I am thinking of buying copies for all my nieces and nephews soon as its done



  • Another issue, looks like besides the music / SFX going back to 0, the resolution that you set in the launcher doesn't stick to the config file either.


Log in to reply