How to set up a private server using Hamachi by logmein

  • This is an alternative method to setting up a Private Server using Hamachi. It is a Virtual Private Network. If nothing else has worked for you. You can try it this way. It's Pretty much sharing your LAN with your friends. We had been trying and trying with other means but to no avail. It drove us mad. I hope this works.

    The first thing you are going to want to do is make sure you have downloaded all of the server files from the main Eco website. It is located under your account and is below the download clients. Next after you have successfully downloaded and extracted the files you are going to want to run the Server Watcher file. It will launch a command window. Let it fully run its course it will open a new window. Here you can change settings like; Network Server name, world generation and what not. When it does open this window though it is ready to test to see if you LAN Server is working. To test this run the game normally and your server name will be located under the yellow LAN list.

    Next you are going to completely exit the server and the games including the server watcher. Then go and download,

    After you have successfully downloaded Hamachi you will need to set up a network within it. If you need help with that there is an easy Tutorial here

    After you have made your network give your Network ID and Password to your friends. Once they have joined you will need to launch the Server Watcher once again. Then have your friends launch the game and copy and paste your Hamachi IP. They do this by right-clicking your name and selecting Copy IPv4 Address. Alternatively you could click the top next to the power button and give them the address.

    They will have to paste the address in the ADD SERVER section in the game. It is located on the top of the server list. It says Address and port but you don't need a port. After that it should show up if not refresh and it should let you connect to it.

    This has worked for me and my friends if it does not please leave a comment.

    I did this on PC I have no Idea if it works on any other OP.

    I hope that this helps.

    P.S. If you would like to join my private server just let me know.

  • I would recommend open ports instead of hamachi unless you have no access to your router in any form.I personally i never liked hamachi, messes up network thinks

  • @NoBlackThunder I have tried and for reasons unknown it never worked for me. I have been using Hamachi for a while and have had no problems with it. It always saves the day. It took us a while to figure it out. Because we weren't sure it would work so the other day we tried it and it worked.

  • Me and some buddies are having trouble doing this. My buddy running the server sees it under LAN, but we can not see it. I've tried hosting as well, no luck. We were unable to get the server to appear as an internet server either using his public IP. Ports have been forwarded in both router/win firewall.

    Being run as an admin
    No errors in the cmd windows that pops up.

    Open to any suggestions on what to check.

  • @Enano and you copied your buddies ipv4 into the add server section? Once you do that it should appear under favorites.

  • We've narrowed it down to windows firewall issues private connection settings.