A little help for a noob



  • Hey, guys!
    I am still new to this great game!
    I wanted to check out the new 4.2 build, but everytime a I want to join a 4.2 server I get the error message: Incompatible version.
    And in the right bottom corner of my screen is still the 4.1 build visible.
    So my question is: " Do I have to download the patch manualy somewhere? "

    Thanks for your help!



  • The game dosn't auto-update. You have to download it from the website, account section.



  • Thank you very much!


Log in to reply