Can't get the server to show up on my public ip it keeps showing up as offline



  • Hi,

    I'm trying to make a server from my pc it works fine on LAN but i just cannot get my public ip to detect the eco server status :/ i have added ip to list but it just throws Offline all the time when server itself is not offline so could some 1 here help me out and give some sort off usefull instructions how to fix this?

    /Thanks



  • i also even opened port 3000 in router and firewall yet server shows up as offline no mather what i do :/



  • okay after checking it again i found out i had wrong pc ip assigned to port 3000 in router so now i corrected it and i do get disconnected client all time now and still status comes up as offline :/

    the error i got is

    Unknown client inactive for longer than 30 seconds, disconnecting client.
    [16:22] Disconnecting client [reason: Inactivity]...



  • if you stand still you will get disconnected



  • I think you misunderstood me there that error comes up when loading server list it tires to get signal but times out in server so then server shows up as offline.



  • did you forget to put it up as public?

    its a setting under network



  • You need both the game and web ports open and forwarded to be listed publicly. By default these are ports 3000 and 3001.



  • Also if you're using Windows, check your firewall. I had to explicitly tell mine to allow ECOSERVER.EXE to bypass public and private network firewalls, even after forwarding ports 3000 & 3001.

    There's also a way to set the IP Address of the server. I don't know how much bearing it has on it, but I changed my router to use a static IP, and the entered that IP address in the ECO server, and it worked.

    But of course like a bad scientist I did like, 3 or 4 things at once, so I'm not sure what exactly fixed the issue :\



  • ah makes sense it worked now but once i got it up it told me some 1 called UltraTM joined my server so i wanna know who is that? is it a bot or something?



  • Unless you set your server to Private = True, then anyone can join since it's just listed in the server list.
    I expect it's just another player who just happened to join your server, either on purpose or by accident.

    If you do set Private to True, make sure you add the players you want to your whitelist. Spelling including upper and case matters. When I added "jhadred" to my whitelist, I couldn't join until I figured out my name comes across as "Jhadred".


Log in to reply