Problems with a Windows 2012 r2 server

  • We are having problems with setting up our server (with alpha 0.3). It is being extremely, extremely laggy and we cannot connect to [server_ip]:3001; however, http://localhost:3001 works on the server.

    There are no server errors...

    We have followed the how to in this forum to set up the server. We have made sure we have the folder ExportedMods. We have run the clients and server as admin... We have made sure the ports are forwarded and the server firewalls allow the ports through... We have made sure .net 3.5 and 4.5 have been installed...

    To make sure whether it is the router or the server that is causing the problem, we started a server on a computer in the network. It worked perfectly... Everything was nice and smooth.

    So is there something that we are missing? Something stupid that we did? lol Or is there something that we should have set up for Windows 2012 r2?

    Thanks for any help. This problem has been quite annoying.

  • Hei.

    ok if you can connect locally on the server and the game works fine there but not outside then it seems there is an issue with your network .. to troubleshoot this i would like you to do the following:

    1.On your server check if you have open the firewall ( Windows Advanced Firewall) also unistall any antivirus that has a build in firewall beside windows own firewall ( like zone alarm )

    2.check if you can connect to the server from the same local network and if its working fine after you completed step 1.

    1. check if you have correctly forwarded all ports on your router correctly ( in case of doupt you can use IIS server and create a new webside on those ports after you turned of the server and seer if you can reach test websides on those , but be aware of that the http protocole only uses TCP . so you might wanna check if you forwarded both TCP and UDP )

    if the above dont help and you have direct access to the server could you connect to the server with the client on the same machine ?

    also if you use UPNP then turn that off and use instead direct port-forwarding.

    and last also do a speed check like with and give tell me what the results of everything is.

    hope that helps for a start

  • Hello,

    I am working on this server with the OP. The server can in fact be accessed via the public address on port 3000. However, the web interface of [Public IP]:3001 cannot be accessed. Ports 2999 to 3001 are opened both internally and externally on the router. I installed the ECO server on a different machine within the same network (Win 7) and it worked flawlessly without any lag whatsoever. However I neglected to test the web interface on 3001 with this test machine.

    The server seems to have all firewall exceptions enabled, without any interference from antivirus software. I can connect to the server from a client on the same network (using the server's local IP) and it acts just as slow and laggy as connecting to it remotely via the public IP does. This leads me to believe it is likely not an issue with port settings on the router (which has TCP and UDP set for 2999 to 3001).


  • Hello again,

    We have seemed to have solved the problem but why this was an issue, I do not exactly know. I am running a Dell R210 which has two internal, identical, NICs which I had bridged to each other to occasionally route traffic through to another switch on the network. At the time of the issue, the other NIC was disconnected and not in use, however the adapters were still in bridge mode. Removing the bridge completely solved the issue with lag and now also the web interface on port 3001 is showing up.

    For whatever reason, the ECO server does not pass data very well through a virtual bridged adapter. We have hosted other servers on this machine and have never had this issue. Perhaps this can help in the development of the game?

    I would be interested in doing further testing if it would aid anyone.

    Thanks for your help,

  • @yaut ahh yea i see .. not an uncommon issue with application binding and network interfaces. ill forward this to a dev and see what he says.

  • Great, thanks!

  • metachronism told me that that you actually can sett the binding in the networks tab. hope that helps =)

  • Thanks, I will check it out!

Log in to reply