i cant connect to a server or my own world



  • i tried it a few times to connect to a server but it nerver workt and thats the code

    <size=150%>Verbindung fehlgeschlagen</size>

    Login info could not be verified. Our auth servers may be down.

    Log File:
    Initialize engine version: 2018.3.12f1 (8afd630d1f5b)
    GfxDevice: creating device client; threaded=1
    Direct3D:
    Version: Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA GeForce GTX 1080 (ID=0x1b80)
    Vendor:
    VRAM: 8079 MB
    Driver: 25.21.14.1967
    <RI> Initializing input.

    <RI> Input initialized.

    <RI> Initialized touch support.

    UnloadTime: 0.395094 ms
    WARNING: Shader Unsupported: 'Standard' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Standard' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Legacy Shaders/Diffuse' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Avatar FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Standard' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Standard' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Pollutable' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Metalness Cutout' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Pollutable FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Metalness FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Pollutable Cutout' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Pollutable Lambert FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Lambert FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Avatar' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/SpeedTree' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/SpeedTree' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Cutout' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/StandardFade' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/StandardFade' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked Metalness' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Triplanar Masked FADE' - Pass 'Meta' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Standard (Vertex Color)' - Pass 'META' has no vertex shader
    WARNING: Shader Unsupported: 'Curved/Standard (Vertex Color)' - Pass 'META' has no vertex shader
    Connecting to 77.22.76.58:3000...

    UnityEngine.Logger:Log(LogType, Object)
    UnityEngine.Debug:Log(Object)
    Eco.Shared.Utils.Log:WriteLine(LocString)
    Eco.Shared.Networking.NetworkClient:ConnectInternal(IPEndPoint)
    Eco.Shared.Networking.NetworkClient:ConnectRoundRobin()
    Eco.Shared.Networking.NetworkClient:HandleIncomingMessage(NetIncomingMessage)
    Eco.Shared.Networking.NetworkClient:<Initialize>b__44_0()
    UnityEngine.Events.UnityAction:Invoke()
    System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
    System.Threading.ExecutionContext:Run(ExecutionContext, ContextCallback, Object)
    UnityEngine.Events.UnityAction:Invoke()

    (Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 45)

    Unloading 6 Unused Serialized files (Serialized files now loaded: 0)

    Unloading 16 unused Assets to reduce memory usage. Loaded Objects now: 87751.
    Total: 164.705561 ms (FindLiveObjects: 4.430230 ms CreateObjectMapping: 4.666319 ms MarkObjects: 155.365527 ms DeleteObjects: 0.243200 ms)

    Connecting to 77.22.76.58:3000...

    UnityEngine.Logger:Log(LogType, Object)
    UnityEngine.Debug:Log(Object)
    Eco.Shared.Utils.Log:WriteLine(LocString)
    Eco.Shared.Networking.NetworkClient:ConnectInternal(IPEndPoint)
    Eco.Shared.Networking.NetworkClient:ConnectRoundRobin()
    Eco.Shared.Networking.NetworkClient:HandleIncomingMessage(NetIncomingMessage)
    Eco.Shared.Networking.NetworkClient:<Initialize>b__44_0()
    UnityEngine.Events.UnityAction:Invoke()
    System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
    System.Threading.ExecutionContext:Run(ExecutionContext, ContextCallback, Object)
    UnityEngine.Events.UnityAction:Invoke()

    (Filename: C:\buildslave\unity\build\Runtime/Export/Debug.bindings.h Line: 45)

    Unloading 0 Unused Serialized files (Serialized files now loaded: 0)

    Unloading 0 unused Assets to reduce memory usage. Loaded Objects now: 87938.
    Total: 167.298561 ms (FindLiveObjects: 4.251598 ms CreateObjectMapping: 4.930284 ms MarkObjects: 157.884287 ms DeleteObjects: 0.232107 ms)

    thats the code and my pc has a i7 and a gtx1080 10gb



  • I got the same issue. I've done the following troubleshooting but no success.

    1. Restarting PC
    2. Restarting Router
    3. Verified Game Files
    4. Checked Windows Firewall settings and the following are allowed:
      Eco.exe
      EcoGameServerPort3000
      EcoServer
      EcoWebServerPort3001
    5. Disabled anti-virus
    6. Disabled firewall
    7. Reinstalled Eco
    8. Updated to latest .NET Framework 4.8
    9. Tested 64-bit and 32-bit
    10. I even dabbled with port-forwarding, which shouldn't matter because i'm not hosting, i'm merely trying to join ANY public world.


  • Make sure you are using the most recent version and have turned off any anti-virus software that might interfere. If that doesn't help, send an e-mail to support@strangeloopgames.com or join our discord on discord.gg/eco for help.


Log in to reply