A way to edit buildings?

  • It seems like, once the building is complete, there is no way to change it. I can't even add something to the exterior. It says "You are not authorized to build here" (even though I am the owner, and I am the only one in the world) so I tried changing it to public and I still not not change anything.

    not authorized.jpg

    This could be serious in the case of a player not building any openings (is there even a game mechanic to get unstuck? or is the player condemned to sit in their hovel until the world ends?), or as simple as not being able to add a door to the existing deed.

    My house has 4 doors. Each one must have it's own deed in addition to the deed of the house. There's no way to add it when it is built, and no way to append it to the deed of the house.

  • Alpha 4 changes all this to be less frustrating :)

    You can use /reopen command right now to reset the building and make changes, but this system is otherwise changing significantly in alpha 4.

Log in to reply