Linux 0.7.8.6 client



  • Ok this is just crazy I have mono installed on my laptop and I am trying to install
    the Eco client on this laptop. (Debian 9)

    There is no real guide that I can find out there either that says
    exactly what libraries you need to have installed in order to run the
    client.

    This lap top is a Toshiba Satellite.

    uname -a
    Linux laptop 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux

    Now I have the mono-complete and the mono-devel installed on this machine
    but the client keeps spitting errors out at me

    apt-get install mono-complete mono-devel libmono-microsoft-build-engine4.0-cil

    I have also tried all of the following as well

    libmono-microsoft-build-engine4.0-cil - Mono Microsoft.Build.Engine library (for CLI 4.0)
    libmono-microsoft-build-framework4.0-cil - Mono Microsoft.Build.Framework library (for CLI 4.0)
    libmono-microsoft-build-tasks-v4.0-4.0-cil - Mono Microsoft.Build.Tasks.v4.0 library (for CLI 4.0)
    libmono-microsoft-build-utilities-v4.0-4.0-cil - Mono Microsoft.Build.Utilities.v4.0 library (for CLI 4.0)
    libmono-microsoft-build4.0-cil - Mono Microsoft.Build library (for CLI 4.0)
    libmono-microsoft-csharp4.0-cil - Mono Microsoft.CSharp library (for CLI 4.0)
    libmono-microsoft-visualc10.0-cil - Mono Microsoft.VisualC library (for CLI 4.0)
    libmono-microsoft-web-infrastructure1.0-cil - Mono Microsoft.Web.Infrastructure library (for CLI 4.0)
    libmono-system-json-microsoft4.0-cil - Mono System.Json.Microsoft library (for CLI 4.0)
    libmono-microsoft-visualbasic10.0-cil - Visual Basic 2012 runtime libraries for Mono

    mono -V
    Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen

    And it still won't work it keeps spewing out a very long error message
    every time I try and start the 0.7.8.6 Beta client.
    Please note I am installing the client on this machine NOT server

    Doesn't matter if I run the x32 or x64 version I get the same error so exactly
    what packages do you need to have installed because I have been googling this
    for a while now and I was unable to find a guide that states exactly what packages
    you need to have.

    The error I keep getting is when I start either Eco.x86_64
    or Eco.x86 is as follows
    Got a SIGILL while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.

    Come on fix your forums I post the actual error message and it flags
    it as spam. Absolutely stupid!




Log in to reply