Can't figure out how to set up server

  • I've looked at the wiki, the forum on here, several videos. I can't figure out what I'm missing. I created the server but it says it is lan and it isn't on the public list even though I set it to be public. Can anyone help?

  • Maybe I can help on your server problem. I do not know installations you’ve made, therefore I mention all steps sequentially.

    • speaking about Windos System (not Linux) and ECO v7.6.3 (Client and Server should be same version)

    • use the SLG web server (should be obtainable from steam also – don’t know details)

    SLG web server.jpg

    • the ingame server works also for my knowledge but could change

    Ingame srvr.jpg

    • start the web server, a window pops up and it takes a while till server UI opens (confirm windows firewall if asked for)

    • set in the server UI PublicServer = true and your server name in Description

    ECO srv.jpg

    • minimize the server windows and let them run in background

    • now start your ECO client, select JOIN, it should show your LAN server

    LAN svr2.jpg

    • select tab BROWSE, it should show your server as public


    This is all to setup a server. If it does not solve your problem, I would suggest to reset windows firewall to standard settings and start the server again.

  • Also you might have to open the correct ports on your router for the PC you are using as a host.

  • Router settings are not required, unless you have a very restrictive, special router. The web server opens the configured ports and firewall asks for confirmation.



    You can try to connect to my server as shown above or try it direct using
    I don’t know your location, it may not appear in browser or very down the list. I leave this server on for the next hour.

  • Nicolausi, thank you for your very detailed explanation I did all as you have said and it shows as lan however it does not show up in browse. You say something about a router however I do not have one and I am assuming that is my problem.

  • Hmm, you saying you don’t have a router, I wonder how you are connected, is it a dial up connection?
    Then I would guess this could be the problem, but I’m not a router and net-guru. Earlier a had a dial up too, but forgotten all about it. A dial up is - lets say – one line and can not handle multiple connections, but should be configurable to service to PC’s for example , but I’ve forgotten how to manage this. I can’t give more advice on this matter – sorry :(

  • I don't have dial-up. I am using comcast's service.

    No problem, thank you for your time.

  • Correction: The standard port number for direct login is 3000 (xx.xx.xx.xx:3000), NOT 3001 as I wrote above!
    And another thing might be a problem in seldom cases, if someone is connected via a proxy server by provider or own, then the proxy must be instructed to pass trough port 3000 and 3001 in both directions.

  • Sounds like you have a combo router/modem from your provider which is tricky for setting up any hosting from your home without the ISP opening up the proper ports I ran into this years ago with Delta Force games and had the ISP take back the COMBO router/modem and replace it with their standard modem only and then I ordered and installed a LINKSYS router as they are very easy to setup for hosting in the security setup options for port forwarding.
    Hope this helps.

  • Networking adapter or driver can prevent Eco-server being public!
    (this may also be an interesting find for SLG to keep in mind)

    Very top on this topic I described how I set up my machine for a public ECO-Server without any problem and even without explicit port forwarding. The server was running over 3 weeks and had nearly 100 players.
    (Quote ECO wiki)
    ECO wiki.jpg

    As I now tried a second (little older) machine to install an Eco-server, it didn't work. I had lots of work and tinkering, compared the system services and settings – nothing worked - finally I installed another networking card in a free Pci slot and surprise: NOW IT WORKED!

    The onboard networking adapter is a NVIDIA nforce chipset RTL8211CL, the motherboard is GA M68M-2SP.
    The bypass is now a PCI Adapter with RTL 81695C

Log in to reply