Can't Get Past Start Screen

  • I'm loading into Eco through Steam. The game loads up and it brings me to the starting screen with the windmills and landscape. However, after the white bar at the bottom of the screen loads completely, nothing happens. I'm not sure what I'm doing wrong, or if there's a button I need to push. There's no way to join a server.

  • You now use your gameport instead of webport to connect, so if you used to connect to port 3001, you would now use 3000 if you used default ports.

    If creating a standalone server on a machine with the client-server already installed through the game, you have to use ports other than the default, perhaps 4000 and 4001, although you always use 2999 as the listening port and share with the client. You may have to check out your support pages for your ISP to learn about your router or google your router make and model for a manual to read information about port forwarding. Usually, your ISP support site will have information on port forwarding for your modem/router. If the router is not from your ISP or they do not have that information for you, there are many guides online about how to do this, and it is a relatively easy process.

    Next important thing: If your server's not showing up, you need to go into appdata/LocalLow/Strange Loop Games/ and delete the Eco folder then restart Eco and it will write new files. To get it to populated you may need to open the filter (middle button between search and refresh) and click 'apply'.

  • @ShaydenMac Sorry just getting back to this.

    However, I'm not trying to start my own server. There isn't a way for me to join any servers when I start the client. I tried deleting the game (as well as specifically the Eco file itself just in case) and redownloading it from steam but it didn't work. There isn't an option for me to enter a world or to continue.

  • Screen Shot 2018-06-07 at 1.49.36 PM.png
    This is a screenshot of the screen that I can not get past.

  • If you're still experiencing this issue, please file a bug report here

    and include the following information:

    Client Version
    Running through Steam or standalone?
    A copy of your output file.
    A copy of your dxdiag.txt file

    Your output_log.txt file can be found here: Local Disk\Users\UserName%APPDATA%..\LocalLow\StrangeLoopGames\ECO

    To get your dxdiag.txt file, click WIN+R and then type in "dxdiag" without the quotes. A window will pop up with information about your computer. Click on the "Save All Information" tab and save the dxdiag.txt file.

  • I am having the same problem, tried every step stated in this post. Please can you speak in simpler terms on the port thing. If this continues I will be forced to ask for a refund.

  • @pumalazooma Since we're in beta, the game can change quickly and something that may have worked a month ago may not be relevant now. Please contact so they can troubleshoot the issues you're experiencing. Thanks!

  • I just had the same problem. I managed to get around it by not using the usual startup icon that links to Steam, but to log-in using my SLG ID by starting the client manually, directly from the executable.

    Looks like something's wrong with Steam integration.

Log in to reply