Eco not recognized as a video game by Windows 10 (others?)



  • Observation:
    Eco is not recognized as a video game and/or a graphically intensive application. This caused my 980m to not be used when launching Eco and was running off intel HD 530 graphics - causing severe lag which I blamed the servers for.

    Repro:

    1. Use a laptop with both dedicated and onboard graphics.
    2. Launch Eco
    3. See that there is graphic / lag issues
    4. Go to Nvidia control panel - manually set Eco to run on dedicated graphics.
    5. Launch Eco - FIXED

    Expected: Eco should prompt PC to use the best graphic option available.
    Actual: Eco does not prompt PC for dedicated graphics - must set manually; unplayable otherwise.



  • Confirmed issue, My laptop is acting the same way.

    https://github.com/StrangeLoopGames/EcoIssues/issues/43



  • Yay, my professional QA analysis skills are still useful.

    If people could test this on Mac / Linux / W 7 / W8.1 would be great. Please also post the OS being used and the dedicated / built in graphics cards being used.

    Also, if you have a laptop with AMD please test this as well.

    -Xzardani



  • There are actually many games which actually not recognized by Nvidia.
    So I was just set my Nvidia setting into default dedicated.



  • Considering a 980m (and most other cards) drains my laptop in under an hour - I don't think that is a valid situation for most users.

    Getting a game recognized by your GPU is pretty important - there are those who are not tech savvy enough to realize that there is a config issue causing lag and will contribute it to the game/server being crap. I mean, I've worked in the video game industry for 2 years and almost did exactly that!



  • Not sure how we'd get NVidia and other card makers to recognize us. I know they're pretty slow at updating their list: on my Alienware I have to constantly go in and tell it to use my 3d card rather than the onboard one whenever I download a game from Steam.

    If anyone in the community wants to help with this that'd be awesome, otherwise we will probably have to wait till closer to launch, or hope NVidia finds us.

    In the mean time you can manually set Eco to use the right GPU



  • I'm not in the video game industry anymore but let me see what strings I can pull at Nvidia.



  • I think the issue is somewhat unity her :/ unity does not run in true fullscreen. Meaning that another software have issues detecting it to be a game. its more a fake borderless window thing they use :/ guess many other games might have the same issues :/

    some reference here:
    http://forum.unity3d.com/threads/shadowplay-not-recording-games-made-with-unity.295050/
    http://issuetracker.unity3d.com/issues/regression-nvidia-shadowplay-does-not-record-gameplay-on-4-dot-5-x


Log in to reply