[Client & Server] Object placed - player moved, can't connect anymore

  • Hello,

    we're having our own server. The issue happens on client - server! Upon placing a road ramp - asphalt (I was staying on a block where it was to be placed), my character got instantly teleported to location interpreted as (-2147483648, -2147483648, -2147483648) - e.g. 0xFFFFFFFF in hex in all coordinates - literally placed to negative infinity. I suspect there might be some division by zero and improperly handled conversion of numbers after.

    Upon disconnecting and attempting to reconnect to the server, I'm stuck at 'Entering the world' phase.

    I'm attaching an image how it looked like:
    teleported to infinity

    The problem can be solved by teleporting back to other player or to specific coordinates.

    If by any chance you have disconnected from the server and didn't teleport (in which case you won't be able to connect anymore), restarting a server will solve the problem by placing you to spawn

    My hardware configuration:
    CPU: AMD Ryzen 7 1700
    Memory: 16 GB DDR4 @ 2666
    Motherboard: AMD B350 Chipset (AM4 socket)
    OS: Microsoft Windows 10, 64-bit; Build 16299
    GPU: AMD Radeon Rx 480

    To replicate: We were able to replicate it multiple times by placing Asphalt ramp (4x4 one) under yourself or under my friend. We tried it few times and it was kinda funny bug in the end. E.g. one player stands at location where ramp is being placed either by himself or by another player. Upon placing, you get shoot into infinity!

    If you need any further information please ask about it.

Log in to reply