Unable to join any server/load one or make a new one



  • Since the update, all servers seemed to lagg (7-03-2018), but it wasn't a really big deal. However, after a crash, I'm suddenly unable to join/make or load any server which makes me unable to play the game. After loading the world etc. the screen just keeps on loading forever (https://gyazo.com/80da2ab7521bdc8e9ce2902f576112db), but it doesn't crash. The only way out is closing the game with task manager or alt F4. Also, people are not able to join the server while I'm loading it, while they previously could be in my server before I got in it as long as the world was loaded, so it doesn't seem to do that either. I have checked files through steam, re-installed the game multiple times through various ways, updated my graphics card, but I can't find a solution.



  • I had this earlier today, and had to uninstall and reinstall.



  • yeah I also did that, but it didn't work, so I don't know what I can do



  • same problem here since yesterday. First the game crushed down, so that I have to end the game with task manager after that I am unable to connect to the server. I have tried two times to install and reinstall the game but without any changes :(



  • same Problem here tried to reinstall couple times. idk where to find some hidden files to clear it all because after a new install my old Favorite servers are shown. anyboddy an idea where i cant find temp file's or something



  • fixed for me guys, u need to looking for the Appdate folder "C:\Users*USER*\AppData\LocalLow\Strange Loop Games\Eco , (USER ur Username). and delete all the stuff in there, than start the Game again.

    pls tell me if it work for u



  • @h0ly86 It worked, thanks =D