Save from pre 7.2 unloadable



  • A save I generated after purchase yesterday is no longer loading after the update. I have am given no info apart from it saying "Connection Failed". This is frustrating. Any ideas?



  • I have the same problem, all parameters are loading but the wheel just turns over and over without launch the game.

    Please, can you fix it?



  • Have you tried to download an older beta from Steam? If this works don't forget to stop updating. You can start Eco without Steam, too. That way Eco won't update automatically. Works for local and online.

    Make a save of your world before switching versions. Just in case.

    If you're playing online keep in mind that client and server version match. Otherwise you can't connect.



  • @Thineboot ty for your help.

    Can you tell me where is the save? MyDocument?

    I tried to play with 7.1 version but i have the same issue. With 7.2 version i tried to created a new world : same issue.

    I tried to play without steam but my account is not reconized



  • You're welcome :)

    [PathToEco]\Eco_Data\Server\Storage\Game.*

    You can register at SLG. Worked for me. Just link your Steam-Account.



  • I'm sorry but still nothing.

    I linked my Steam account. but when i want to connect to eco without steam i have a message "failed to login, Error getting response stream (Write: the authentication or decryption has failed): sendfailure".

    I'm sure about ID and password



  • @nas28 said:

    I'm sorry but still nothing.

    I linked my Steam account. but when i want to connect to eco without steam i have a message "failed to login, Error getting response stream (Write: the authentication or decryption has failed): sendfailure".

    I'm sure about ID and password

    I just tried to connect to a serve but i have no one serve on the list even when i refresh.

    I jsut reinstall the game nothing



  • Well, Steam closed, started Eco within Steam folder, Eco recognizes me, logged out, entered SLG Username and password, Join, entered an abandoned world.
    So it's working for me right now (0.7.2.5) and was working in prior versions, too.

    I could try 0.7.1.0 or any other version if it's still a problem for you ... and if you tell me what server you're on.



  • @Thineboot

    I just tried to connect with my SLG ID and password i have the error message failed to login, Error getting response stream (Write: the authentication or decryption has failed): sendfailure".

    I succeeded to connect to SLG webside right now.

    I tried to play to another computer and i succeeded to but to my main computer i cannot.

    If i tried to play with an another version (7.1.X) the error message is displayed connection failed



  • Don't mix up your username at SLG (nas28 ?) and your user ID at SLG (slg1xxxxx).

    There are three 0.7.1.x versions available at Steam...

    Have you saved your world?
    Are you sure that you're running the version it was created on? While there should be no problem there could be a problem.
    Have you tried to delete your world and create a new one and joining the new one? Just to exclude possible causes.
    After downloading verify integrity of game files: Steam >> Eco right click >> Properties >> Local Files (Tab). Just in case something went wrong. And I know that something can go wrong at first-hand ;)



  • @Thineboot

    I tried my username SLG, my user ID SLG and my username Steam, the same error message displayed.

    When i start with old version, a moment during loading map is coming back to Windows and saying Connection Failed.

    I saved my word, with the actual version, i created a new word but i cannot joint it, always the wheel is turning.

    I checked the integrity and is perfect.

    I copy/past the all folder to the second computer (which game works) to the first, i have the same problem



  • Login says Username, just use your SLG username as you're connecting to SLG, not Steam.

    So you have two computer, one is working as expected, the other is not. In other words Eco works also on your end but not on your primary computer. Is this correct so far?

    Have you checked out EcoWiki?

    You may also make visit at GitHub and check EcoIssues. Maybe you'll find a simple answer or you can file an USER ISSUE as devs check in there frequently.



  • @Thineboot

    I tried with my username but nothing.

    that's right, i've 2 computers. i will open an issue on github.

    Ty for your help



  • How to do a Clean Server Install for New Update
    @rentechd said:

    [...] NOTE: Starting with 7.2 your saved files are now Game.eco and Game.db and you need to save both If you are more then one release away you must update through teh releases so your world can migrate to the final release you want to be on. [...]