Can't connect to 7.2 server due to version conflict even though client and server updated



  • I have updated client and server via steam to latest version.
    Server is shown in client as incompatible with version number 0.7.2.0
    If I try to connect I get the error message that the server's version is incompatible.

    I have uinstalled and reainstalled both, client and server.
    I have restarted the server and the computer several times.



  • This post is deleted!


  • you can change the client version by right clicking Eco in steam: properties > beta, there you can select 0.7.2.0 as client version



  • I have the exact same problem.

    My client is up-to-date, my server is up-to-date. But I can not connect to my server because of invalid versions. It worked just fine until this update came out today. This update seems to be a clomplete mess. My hoster had several problems to get all the servers back running today since there were changes made to the server which just let all the servers crash while starting.

    And after my hoster had all problems fixed, this new problem emerged. Thats just crap in my eyes.

    And no: I can not change the client version as Jilreth described it (steam: properties > beta).
    If i go into properties -> beta I can join some beta programs if i like, but i can not change any client version.


Log in to reply