Unable to login was logged out about hr ago



  • I am unable to login

    ihttps://i.imgur.com/6fk6YbH.jpg



  • This happens from time to time, steam might be down for maintenance, happened to me before, it only lasts a few minutes.



  • But I am not a steam user I am a slg user, and my house m8 who as linked his stream account is able to login without a problem, as a server owner I can't even admin my server right, I am fuming at the moment.

    I will keep trying tho



  • Sorry read the error message wrong (it's late here),

    I tested logging out and back in on my account and it worked, if this issue still persists, try reaching out to SLG on discord, maybe your account is glitched?



  • I am still locked out of there discord, I have dropped them a email but this is not accpetable for for over £70 been spent on this god dam game, I can login and out of my account on the website but the app just returns that. it's late here two it's almost 1 am to find out I fully locked out of the game.



  • I used my last key and created a steam version of the game and found out that was also not working, that one let me in the game but wouldn't load a world local or remove and the remote server was broken, I deleted the user folder of eco and reloaded the game, it then let me run the game locally and remove again, I have no idea what the hell happened there, it seemed something got upset and just broke the game badly.



  • You can also link your SLG account to a steam account to not use up a key. This will give you access to the game via steam using the same key ;)



  • Well no where did it make that clear and I don't want to use steam so I didn't know if it would disable my slg login, was not worth the risk at the time, but hey using steam didn't fix it it was the user data full stop what was broken and since the steam and normal version seen to use the very same folder it didn't fix it, having the game rebuild it fixed it

    Once again a thing I had to find out myself, but hey it's not that bad it means I can fix this if it happens again.



  • Thanks for sharing the fix.


Log in to reply