macOS High Sierra support



  • I downloaded the mac version of the latest beta 7.10 and tried staging version 7.10#B9d4fcf5 and but when I double click on the application I hear some birds chirping assuming it's game music and a couple of seconds in I see the application not responding anymore.
    Screenshot below
    Screen Shot 2018-02-12 at 11.29.36 PM.png
    Specs
    Screen Shot 2018-02-12 at 11.31.24 PM.png

    Similar post 4 months ago with no result



  • Me and my girlfriend just bought the game as well for our Macs, running into the exact same problem. Which is disappointing as we were quite hyped.

    Highend Mac, it seems a software bug.

    Some assistance or a hot fix would be great, would love to play this game instead of requesting a refund.

    Screen Shot 2018-02-14 at 19.51.09.png



  • Hey, that's .. tricky. Because researching which platforms were supported only showed confirmation that it indeed also support Mac, had we known that it does not currently work we would not have purchased. How does one go about getting a refund on this? Only just purchased.



  • I'm assuming you meant "We are currently not advertising mac and linux as supported" but I did my basic search on this forum to make sure it was supported on mac.
    1 day ago someone asked if the game was supported on Mac's and you said to use the search function so I did and the first post that comes up is that it is supported... [proof]



  • This is disappointing, since previous versions did work fine on macOS and Eco has clearly been advertised as supporting macOS since the original Kickstarter (I'm a 4-license holder since then).



  • Screen Shot 2018-02-16 at 22.27.02.jpg

    I just bought eco based on the following page direct from strangloopgames, it shows a client for Mac. please let me know how to get a refund.



  • Do we have an ETA on the next patch to come that may stabilize this issue for macs?



  • same problem here



  • Same problem too..



  • Just tried it. Had also the screen for a real long time. Then I want go some coffe, talked with friends... maybe 5 - 10 minutes. Came back, still was there, then minimized, done some other things. Maximized it again, and it was loaded.

    So just seems to take an insane amount until it's loaded.

    Edit: Tried it again, it now takes about 3 - 4 minutes to load (on a SSD). On a HDD it could be even worse



  • Wow, me too. I just had to wait a couple of minutes (2014 retina iMac).

    Great find!


Log in to reply