Can't get into the game



  • Hi all, total noob here. I've installed the game and logged in, but when I click on new and create a world name, it loads for a second or two, then nothing, it just shows the screen with the trees, and birdies singing, and I am at a loss here. Please be kind with the comments :)

    thanks
    PK



  • It's the single player I want to get into, please help?



  • Single player, if you have not seen on Discord, tske over 10-45 mins to load and make a world.



  • Wow I did not know that. But once its loaded and saved, it should bring it up again pretty quickly next time I want to play single player? Thanks for answering by the way :)



  • Well I left it running all night, and it still didnt create a map, when I got up this morning, it was still on the forest screen, no map had loaded :(



  • Wish I could help you. I know it is based on your machine's CPU/RAM so if your machine can not handle it, then it will either take way too long or crash.

    They are still working on it tho!



  • @DS9PeaceKeeper I think there may be some confusion here. In order to play the game single player, you also have to download and run the Eco server. You can find the server in the same place as the client download: ecoauth.strangeloopgames.com

    Once the server is up and running (could take a while as MW said), launch the game client and it will show up in the server browser. Just make sure the client and server are the same version or they will be incompatible.

    Hope this helps!



  • Nes, There is an option to play single player in Eco. The menu option is New. It will run a server for the player(all world info is stored in the client's folder) I have heard many people cannot run Solo Play(many cuz of hardware) while a few can.



  • Exact same problem here, it worked fine when i first started the game, it started generating the world and was soon playing the game. Later when i wanted to play again the next day, i pressed continue, but nothing happened. Trying to load my save did nothing either. Trying to generate a new world also doesn't work. I have even tried removing the files for the game and re-downloading, no dice. So something is definitely broken in the game.


Log in to reply