Played with no problems day one. Since then, can't log in

  • I bought this game back on the 23rd, and had no problems loading, or loggin in, or anything. I did find a bug quite quickly, but i forgot to replicate it before reporting it.

    However, that bug isn't why I'm here. On the 24th, I tried to log in, and it just said "Failed to login; The request timed out." I figured, okay, maybe there is an update. Only, I didn't find anything about the servers being down, or anything. But, I just left it. Yesterday I was gone all day with the family for Christmas, so didn't get a chance to try it. This morning, I tried to log in, and got the same thing. Only, I tried something different. I loaded up task manager, and went to where I can view the activity, and there is NO activity on the network from load of the game, all the way to the point I quit the game. I added an exception to the Windows Firewall, and that didn't resolve it. I even connected to my phone's hot spot, and the same thing. No network activity.

    In case you want all the nitty-gritty stuff, I know it can be useful for diagnosing issues.

    Running Alpha
    Windows 10 Home Insider Preview x64
    AMD FX-8350 @ 4GHz octa-core
    16 GB RAM
    nVidia GT 960 with 2 GB vRAM
    Wireless N 2.4 GHz
    TP-Link Archer C7 (running latest firmware)
    CenturyLink Fiber Optic, download @ 100 Mbps, upload @ 50 Mbps

    I had a similar issue with Need For Speed Hot Pursuit the same day that I started having this problem with this game.

Log in to reply