Clays Toolkit - v2.3 - For Alpha 6.3.0



  • Oh there's some swedish in there. Let me google translate that:

    "An exception error has occurred in the target of an activation.
    The underlying connection was closed: A trusted connection for the secure SSL / TLS channel could not be established.
    The remote certificate is invalid in accordance with the validation procedure."



  • Hi @Ekke ,

    Thanks for reporting this, I will deploy a fix later today, I think I know the issue already

    Thanks,



  • Also while testing the home function I did /home-add 1 on a property and when I later did /home 1 I ended up somewhere in the middle of the earth and nowhere near my home that I set. I also tried to do /home-add Ekke but no luck.



  • Hi @Ekke

    That is strange, was the server restarted in between the addition of home and the using of home?

    Also, what do you get when using command /home-list ?

    Thanks,



  • I did some more testing and instead of /home-add 1 I did /home-add e on a bigger plot and that teleported me way up in the air. It's on a private localhost so the server is restarted between every single update I make to check for errors.

    Could it be that if I teleport to home 1 it teleports me to coordinate 1? Here's what I've tried + results:

    /home 1 - Teleports me to complete darkness and if I do /unstuck I might end up on the other side of the world
    /home 2 - Same thing
    /home e - Makes me fall from the sky to the correct position (but I would land on the roof if there was one)
    /home ekke - Same thing
    /home abc - Infinite fall loop



  • That seems strange, I will execute more testing from my end, but I was not able to replicate this behavior,

    Until than,

    Thanks for reporting @Ekke



  • On another note, how do you set rules for the /rules command? :) Can't find any info on that.



  • @Ekke

    https://claystk.info/help/mods
    Scroll to the bottom, it's the last one.

    Thanks,



  • A new version has been released, not worthy of it's own thread so please read the main thread as it was edited.

    Thanks,



  • Following commands does not exist according to the game:
    motd-send
    online-count (online works however)
    online-admins (admins-online works however)

    Following might not work (Not sure because I'm the only one on the server)
    top

    Following commands produces an error code (must note that I tried to slap/punch myself when I got errors)
    punch
    slap

    Error code:
    Caught exception: Caught exception invoking RPC SendChat on ChatManager!

    Ett undantagsfel har inträffat i målet för en aktivering.
    minValue can't be larger than maxValue.
    Parametername: minValue

    Stack:
    vid System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    vid System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    vid System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    vid Eco.Gameplay.ChatManager.InvokeCommand(String commandName, MethodInfo method, String args, User user)
    vid Eco.Gameplay.ChatManager.ProcessAsCommand(String text, User user)
    vid Eco.Gameplay.ChatManager.SendChat(ChatMessage msg, String text, User user)

    Following simply doesn't work
    rules - I've added a rules.ctk file in /root/ClaysToolkit/ and I've tried rules.ctk and Rules.ctk, I've even tried to add the file to \Mods\ClaysToolKit but it still says that the server has no rules.

    Other notes
    I'm still having issues when trying out "home-add 1" and teleporting to that home but I'll try it out on a "real" server soon and I might get back to you about that :) Currently I'm trying out the modpack in localhost. And thanks for doing a great job.



  • I will have a look at your list later and will reply with details about each,

    Thanks @Ekke for taking the time to produce the list and giving such details!


Log in to reply