Setting up a ECO server on Ubuntu (other linux is probably very similar)

  • Ok thanks :)

  • I'm in voice chat if your on discord.

  • @kicker22004 ok, i can't do voice chat at the moment though.

  • hmm when is a good time for you? It just makes it easier to assist so we don't fill up this chat. Lets chat in discord support section k.

  • The instructions in this post worked for me to set up a Eco server on Ubuntu 17.10.


    1. When installing the beta version of Mono (from link: )

      At the time of writing, the instructions there are for Ubuntu 16.04, 14.04, and 12.04.

      On Ubuntu 17.10, I followed the instructions for Ubuntu 16.04, which worked despite not being for 17.10.

    2. There's a known bug with tooltips on the Linux server:

      This bug is still present in - it's annoying, but doesn't pose a serious obstacle to running a Linux server.

    Additional to this, all configuration changes must be done manually to the files in the Configs/ folder, as the GUI configuration editor doesn't work on Linux.

    I would suggest:

    • Configs/ - change the backup period from 4-hourly to 1-hourly, with 48 backups retained.
    • Configs/ - add a Description line.
    • Configs/ - add yourself to the Admins list. (Use your Strange Loop Games id - i.e. slg12345.)

  • @lws said:


    Actually I am having the same issues with Ubuntu 16.04.3 and Mono

    What I found out is, that if you precreate a world locally on your windows PC, copy it over and then start the server, it surely will work.

  • Hmmm .. I have start the local on my PC the eco server unter Linux Mint 18.3 with mono and become this

    which mono version must installed, the dev or completed ?

  • Seems I should visit this forum more often :P. Hey guys if your running debian based you should look into my tool ELSM.

    Video guide:

  • @kicker22004

    Debian 9 with Google Cloud. I get to the part in your video where you say "hit Back" to load the world and it starts throwing this error image.png

    I installed lsof and retried running ELSM and it had me just stop and start the server again. Going to check if it works.

    Edit2 Electric boogaloo: I threw in a firewall rule each for ingress and egress with the Google Cloud stuff and was finally able to connect. It seems to work! Thank you so much for making this.

  • I tried the ELSM today and got the following error on server startup:

    --BEGIN DUMP--
    Dump Time
    02/17/2018 19:57:25

    System.AggregateException: One or more errors occurred. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Newtonsoft.Json.JsonSerializationException: Could not create an instance of type Eco.WorldGenerator.ITerrainModule. Type is an interface or abstract class and cannot be instantiated. Path 'TerrainModule.Modules[1].Modules[0].Default', line 76, position 22. -- Full dump: Crash AggregateException 02175725.ecodmp

    I tried 7.1.1 and 7.1.2.
    Is this a mono-related error or did I forgot something? :D

  • @kicker22004
    What would be the process for updating the server?

  • @kicker22004
    Thanks so much for your work here, I subscribed your channel in support hope you get to monetized again soon. What I the recommended way to reset the world and start over? It did seem that my world upgraded automagicly to the latest beta when I created it even though not in the list.
    Hmm guess I should look at the menu closer since there is a world reset option....

  • Getting following on startup

    [06:49] Initializing ControllerManager...
    [06:49] Initializing DisasterPlugin...
    [06:49] Initializing BackupPlugin...
    [06:49] Initializing PropertyManager...
    [06:49] Initializing WirePlugin...
    [06:49] Initializing DifficultySettingsFinished in 2.6ms
    [06:49] Initializing ChatServer... Finished in 2.6ms
    [06:49] Initializing EcoSim... Finished in 3.9ms
    [06:49] Initializing MinimapManager... shed in 0.5ms
    [06:49] Initializing RouteProbingPlugin... 151.8ms1ms9ms.0ms
    [06:49] Initializing WorldLayerManager... Finished in 0.9ms
    [06:49] Initializing EconomyTracker... Finished in 1.5ms
    [06:49] Initializing WorldObjectManager... shed in 0.8ms
    [06:49] Initializing EconomyPlugin... Finished in 1,347.3ms
    [06:49] Initializing RoomPlugin... Finished in 21.3ms
    [06:49] Initializing ObjectivePlugin... hed in 5.0ms
    [06:49] Initializing Legislation... Finished in 2.2ms
    [06:50] Initializing WebServerPlugin... shed in 73.5ms
    [06:50] Initializing DiscordPlugin... Finished in 405.5ms
    [06:50] Server Initialization finished in 4,299.9ms.4ms
    [06:50] Failed to start UDP client, LAN discovery may not be available. (Exception:

  • How can I create new laws and all that stuff? It keeps saying "must access from server"

  • Where do I get the newest server version for version 7.2.1 ? I cant`t find anything.

  • Just to say that's always working fine, tested on ubuntu server 16.04 LTS, (mono EcoServer.exe -nogui ) dont omit to add mono repo like on this page ;) So , great job for this game guys!! waiting for a headless server now, webbase GUI is a good idea.

  • @AngelEpa I get the same error, did you find any fix for this? :)

    Edit: There is a newer release available for download which works for me :D


  • Initializing WorldGeneratorPlugin...
    Generating world 4km²...
    Generating terrain...
    Caching world data...
    Failed to post server listing to remote service: Error: ConnectFailure (Connection timed out)
    Generating plateaus...
    Failed to post server listing to remote service: Error: ConnectFailure (Connection timed out)
    Carving rivers...
    Generating special features...
    Ticking (Pass 1)...
    Initializing world layers...
    Failed to post server listing to remote service: Error: ConnectFailure (Connection timed out)
    Ticking world layers...
    Failed to post server listing to remote service: Error: ConnectFailure (Connection timed out)

    I become this Message all Time when i load the Server after some Minutes. The World load and the Message is coming, then World Cache is loading, after this the message come... Any Idea ?

  • For anyone else that is running Debian such as myself to get the mono package do the following

    apt-get update
    apt-get install unzip
    apt-get install mono-complete

    Log into your account to see what the latest server is and download it using wget
    there are several examples listed above on how to use wget or do a man wget
    for help.

    Use unzip to unzip the server that you download again man unzip for help.

    I would also recommend running this as a separate user instead of just making
    a directory.

    do the following:

    adduser eco
    su eco

    You must be root when you are doing this
    This will add the a user called eco and then change to that new account
    that you just created and then take you to the home directory for eco which
    should be /home/eco

    The process of getting an eco server setup on Debian was really easy. I do have
    30+ years though of running Linux. :)

  • Hey
    I followed your tutorial but every time I start the server, it looks like it is starting, right until world gen:
    It runs for between 40-80% (seems random) then suddenly writes "Killed" and it shuts down.

    Anyone know why?

Log in to reply