Alpha 6 Broke (Almost) Everything

  • So, Alpha 6 seems to have broken just about everything. First bug we came across was a duplication bug. If you link a stockpile to a crafting bench and order something you don't have the resources for, then place a stack of a resource you need, quite often the stack would disappear from the stockpile with a message that it was added to the project, but then reappear a split second latter and repeat the message and reappearance, etc. It could go on indefinitely (I once had it happen for a 5 minutes until the project had all the resources needed) if you move around while it is happening. Not sure if it would be a problem with client or server side, but it happens on every server I've been on and to other players as well.

    Next bug is one where weight isn't removed from your inventory when you sell items at a store. Also, sometimes weight would be added to your inventory when you fail to buy items from a store, such as not enough space, carry weight, or money. This ghost weight is fixed only from a server restart, and again, it has happened to everyone on our server.

    Yet another bug is also related to shops. I brought a large cart with me because i was going to buy gold ingots to make more currency to put in circulation. First, i tried to buy 50, but didn't have enough carry weight, so, because of the previously mentioned bug, my inventory was "full" even though i had nothing in it. I decided to try and link the cart directly to the shop instead, and that worked at first. I bought 17 ingots, and they were put in the first slot of the cart. I then bought 100, the shop took the money, the ingots disappeared from its inventory, but didn't appear in the cart. The cart did add the correct amount of weight to it as if the ingots were added, giving it ghost weight just like my inventory had.

    Lastly, we had an issue where moving the mint to a different spot in the same room on the same property caused me to be unable to make more of the currency. When I typed in the name of our currency, it just created a new one with an identical name, and I can only make more of and edit the name of the new currency.

    Performance also seems to be significantly worse than previous alphas. If you want logs from the server, you'll have to contact the server owner. I'm not sure who that is, but the server is the Dark Cubes server. You can find a link to the discord at their site:

    I hope they are easy to fix and make a hotfix for. These have happened on every server I've been on, so it isn't only on this one.