server won't load, stops right after world loading

  • the server i'm running works fine for 1 to 5 days and then suddenly it crashes and after that it stops working

    when i try to open it again it stops right as the world is done loading and if i create a new server to put the world file in it has the same issue and the new server works fine untill the worldfile is put in it

    this is the crashdump i get:
    Crash 08024728.ecodmp

    and these 2 are from the old server i had untill i tried starting it from scratch:
    Crash 07313043.ecodmp
    Crash 08011513.ecodmp

    i hope someone can shed some light on what's going on as i can't gather enough information from the crashdump to know what's wrong unless i have access to the sourcecode which i don't have the money to buy access to

  • Howdy!

    Are you hosting the server locally ? What OS do you use and what .net version do you have installed?
    Have you tried to use a backup ?

  • I host it locally on my 11 year old desktop with a 2.5 GHz AMD athlon dual core cpu, 8 GB DDR2 RAM Windows 7 64 bit, .net framework 4.6.2 and also true 4.6.1

    I have tried reinstalling the entire computer and same issue came

    I have also tried using my main desktop for this and the server part works fine but as soon as I put in the Game.ECO or one of the backups the same issue arises

    I have also tried starting the server over completely and the same issue arose

    It's quite possible that this is an error that only occurs during the startup of the server because all the 5 backups are affected meaning it probably keeps running even if the error occurs and keeps saving the world and after 3 hours all the world files are overwritten

    The conclusion I arrived at as well as a bunch of friends is that the server computer which is 11 years old might have some defects due the wear but either way I think it's best to find out the actual cause rather than just guess

    Sorry if there's some wrong words in here, I had to use my phone to write this as my computer is nowhere near me

  • If you wish I can also upload the Game.ECO and the backups

  • its possible that there are write errors to the diskdrive. but it is hard to say what is at fault . maybe the drive .. maybe memory issue .. maybe some odd .net bug that might be nothing new. But it is working well on your computer right? but the issue only happens on your sons computer?

  • it doesn't create the error on my main desktop but i can't load up the world that has already made the error

    at least i have the means to check if it's a write error caused by the HDD as i have plenty of those lying around and one of them is brand new, i don't know why i didn't think of testing that but i will do that in a few hours when i have the time.

    btw it's not my sons computer it's just one of my old computers which i use as the server because the entire server would lag if i ran it on my main computer which usually run high end games

    i doubt it's a .net framework error as i've had the exact same error after a complete reinstall of windows 7

    i'll write if it fixes it with a new HDD but i think it will take about a week for me to test as it doesn't happen right away

    thanks for the help so far and i hope it's just a write error in the HDD

Log in to reply