Struggling setting up a public server

  • Hey, so I installed EcoServer. it's been fun playing solo a bit. But when it comes to making it a public server I'm stuck.

    I have mostly been following this tutorial. Pretty good tutorial, but I still can't figure it out.

    I can't access my server other than by using localhost. My server isn't publicly visible in game, and I can't access the associated website remotely either.
    I have been trying to connect to the <myIP>:3001 website from my phone on the local network, using the local ip of my pc, no success. It doesn't work with my public ip either obviously. All i get is a timeout. I can see it fine with localhost:3001 from my pc.

    When i try using <myIP>:3000 (the port of the server not the website) I don't get a timeout but an invalid http response. Which is interesting because the same rules are set up for the two ports, both in the windows firewall and my router.

    I've tried this website too and I have the same results. :3001 is a timeout and :3000 is a success.

    So the problem can't be the router as it doesn't work on the local network either. And it can hardly be the firewall. I have the rules set. I deactivated windows firewall for a bit and tested, it didn't work better. So I'm at a loss.
    I don't have any other firewall. I have avast free version that doesn't contain a firewall, and nothing else. I'm on windows 8.1 by the way.
    And have EcoServer set to run as an administrator.

    This is my network config in EcoServer. Nothing special. .
    I tried putting <myIP>:3000 instead of Any. Both public and local. It didn't help.

    When I look at the resource monitor I see this
    The system process is related to the eco server. When I close EcoServer the process disappear. So it isn't a conflicting processus.
    I don't know What is going on with the UDP port, it wasn't in the tutorial. I set some rules to allow it through too, both TCP and UDP, It didn't help.

    This is what netstat tells me
    Both the server and the associated website are listening. Even though the website can't seem to communicate with the rest of the world. I don't know if the fact that they have different local ips should worry me.

    I pretty much tried all I could think off. Pls send help.

  • I still can't get it to work. I changed the ports for the game server and the associated website, and I get the same results I described above: From anywhere else than on localhost, the game server is responding, but the website is ignoring absolutely everything.

    By now I'm convinced I don't have any firewall or router problem. And that there is something wrong with my EcoServer. But I can't find what.

  • Not much new, still the same. There has been those strange disconnecting happening in my server I haven't payed much attention to it. But maybe it's relevant.

    Here I just started my server and didn't attempt to connect to it. There is nobody on my server, yet I still get those logs: Always by packs of two.

    Edit: I get those messages 30 seconds after I refresh the "join a server" board in the eco client.

  • You must open firewall ports,
    2999-2999 UDP (I think Login) to Every single programs.
    3000-3000 TCP (Gameserver) to Any programs.
    3001-3001 TCP (WebServer) to All programs.


Log in to reply