6.5.1 massive lag spikes every few seconds



  • After updating to 6.5.1 i have noticed from the start of a new world, that every 3 to 4 seconds everyone on the server gets a massive lag spike. the game is not enjoyable like this. The server also fails to do any game backups which means that each time we play it is from scratch.

    My system
    AMD Phenom II X4 955 Black Edition,
    NVIDIA GeForce GTX 560 Ti,
    6GB RAM
    OS:Windows7 x64



  • have you tried playing other servers to see if you are getting these same lag spikes?



  • I don't play on public servers. I run my own.



  • @Linrox
    Moin.
    Since 5.6.1 the game has a more complex graphics options menu via ESC > Advanced. Try to disable "Bloom" and "Fog". It could also be helpful, to set the normal graphics option to: Shadow Quality = fastest / Foilage = Max.



  • I have reduced all graphics settings as suggested to lowest possible- Shadow quality, Foliage quality, view distance, mini map detail no music, and turned off bloom, fog, sunshafts,atmosphere scattering, realtime reflections, vibrance.
    When i start playing on these settings the game is better for a little while but it gradually goes back to lagging every 4-5 secs for 1-2 secs duration. I have also noticed that the client eats all my ram and gets unplayable lag and then it will error, with an "out of bounds" error.
    I posted a bug months ago (when i was using 5.4 version) about a memory leak in the client and it seems that it STILL has not been fixed. I have even read people with 16GB having the same issue.

    I believe the memory leak is the cause, and the lag is the symptom.

    It would be nice if i could hear back from one of the Devs on this issue



  • Moin.

    Have you turned your map on, when you have lags?

    On my system (FX-8350 / GTX 960-4GB / 8 GB RAM) ECO runs properly between 35 and 95 fps. The only time i see lags is, while i moving arround having the map turned on.

    With map turned on i have 25-35 fps, with map on and max. zoom in map fps break down to ~10.