5.6 Mortared Stone placed by Quarry into a Storage Chest

  • I'm a little stuck here. I built a Quarry machine, had it pump out some Mortared Stone, but the last 17 or so of it went into a Storage Chest (which ought not to be able to happen, since the Storage Chest can't store carried items and despite the fact that there was a Stockpile with available space in range of the Quarry).

    Now, I can't get the stone out of the chest, either by transferring it to my own Carrying slot, or moving it to my Cart or to the local Stockpile, and the Quarry keeps putting any new stone it makes there and not into the Stockpile. I've also tried moving the stone into one of my action bar slots and into my backpack but always get the "Mortared Stone can only be carried" error - the same error I get if I try and move it to a Stockpile, or to my Carrying slot.

    Am I toast here? I mean, I can't get rid of the chest (since it's not empty), nor can I use this Quarry any more (since it's misdirecting the stone). Anyone know of any way around this?

    I've also logged this into GitHub as per the "How to report bugs" post, but figured I'd post here in case some bright spark on these forums might know of a way around this, since this is now a major roadblock in my game (short of rebuilding a quarry in a new house with no nearby Storage Chests I guess).

  • Not only did it go into a storage chest on the server I am on but it also got put into the fuel slots of my kiln!!MsKiln.png

  • Yeah, I haven't figured a way to get around this bug. It's a basically a show stopper. I can't stop my Quarry from putting the Mortared Stone into a Storage Chest, and once it's in there, I can't get it out of there, or indeed, kill the Storage Chest.

  • Try to get the stone out of the fuel slots of the kiln, it's worse cause you can't use the kiln anymore.

  • Sorry to hear it Flix79 - I couldn't find any way to stop it from doing it either. I pretty much gave up on that game and started a new one. :-(

  • um question for you guys with storage chest issues... why dont you go to your kiln, and go to the storage tab, then uncheck the green checkmark for said chest and tada... it wont be linked to that chest anymore.(atleast thats how thats suppose to work)

    as for the fuel i got nothing on that one :(

  • Well, on my new game, I'm now making sure to do that - on every build, especially the Quarry, I check and see what it's linked to, and make amendments as necessary depending on whether I'm ordering something that should go to a Storage Chest or something that should go to a Stockpile.

    Another (very helpful) user has also pointed me towards some dev tools that may assist in killing the now unkillable storage chest in my old game, which I'll try loading at some point and seeing if that works (to at least recover that game).

    Still, it's obviously a bug and one that needs fixing (hopefully soon), since without admin rights, you'd be pretty much stuffed as it gates any further advancement down the technology tree if you could even (properly) make mortared stone.

Log in to reply