[gelöst] World regeneration Server stürzt ab



  • Hallo eine rückfrage an euch vieleicht mache ich ja was falsch oder habe was falsch verstanden.

    Ich habe im EN Forum gelesen das wenn man den Meteor auf dem Server ausschalten will müste man die Welt nacht dem umstellen regenerieren.
    Der Server läuft ohne Probleme nur wenn ich die Welt regenerieren lassen will ist der Server schrott.

    Zu den daten:

    .Net ist alles aktuell
    Server Version 0.5.5.4
    Windows 7 und 10 wurden getestet beide 64bit

    Test PC 1 win 7 64bit 16gb Ram i5
    Test PC 2 win 10 64bit 16GB Ram i7

    Der Server wurde schon mit und ohne Adminrechten gestartet.
    Ich dachte schon es liegt an der Weltgröße (100x100(1km²)) und habe diese veringert auf 75x75 aber dann stürzt der Server beim Starten ab.
    Der nächste versuch war den Server mit Standarteinstellungen zu starten und nur in der Disasters.eco den meteor auf false zu setzen das keiner bei ersten Start generiert wird.
    Der Server Startet zeigt aber auf dem Web interface die Zeit zum Einschlag noch an.

    Hatt einer von euch noch eine Idee wie man das lösen kann?

    und bevor ich es vergesse hier noch der Server Dump:

    Crash 05140259.ecodmp



  • You can't for some reson generate worlds with odd numbers.Doing so will crash the server when you are close to completing the world generation. So change to 74x74 or 76x76



  • Thanks for the answer.

    But if i change the settings to 74x74 the Server Crash at the Finishing.



  • Solved



  • Für alle die eventuel das gleiche Problem haben.

    Ihr müst die Weltgröße auf einer gerade Zahlstehen haben und ganz wichtig Ihr müst den Server Stoppen und dann im Ordner Storage die Datei Game.eco löschen und den Server dann starten.
    Der Server erstellt dann eine neue Welt in der eingestellten größe.

    Der Fehler wurde mit hilfe von Ravster gelöst.



  • There seems to be an issue with odd numbers in the world size. so if you cant divide with 2 that the game will crash .. Issue is reported =)


Log in to reply