Client runs on bad GPU



  • Hello,

    I have a problem with the client.
    I think it runs on my integrated Intel GPU which is not powerfull.
    So i play with 5 fps...

    And obviously i would like run Eco on my nVidia GPU.

    I see in the "output_log.txt" this:

    • Initialize engine version: 5.2.2f1 (3757309da7e7)
      GfxDevice: creating device client; threaded=1
      Direct3D:
      Version: Direct3D 11.0 [level 11.0]
      Renderer: Intel(R) HD Graphics 4000 (ID=0x166)
      Vendor: Intel
      VRAM: 128 MB

    Thank you for help.



  • You could try via the Nvidia control panel by setting it to high performance.

    You could try the switchable graphics fix via the BIOS (if ur laptop has it) it basicly makes you run everything on either the Nvidia or the Intel.(this does cause the laptop to loose power faster and get hotter).

    With the Integrated that is probs the best it will run.



  • In the nVidia control panel, it's set to nvidia High Performance. But i'm still at 5fps.
    Oh and i have a Nvidia GeForce GT630M with 1 GB dedicated VRAM.

    I will try to change in the BIOS later.



  • hei. i guess you run the game on a laptop? its possible that some those sometimes not switch (like when you run on battery power) normally you should be able to switch them easily via a hot key or a button in a control panel



  • Hey.
    Yes a laptop. I don't have hot key or button in control panel.
    I check the BIOS too and no results. :(

    Usually i choose in Nvidia Control Panel, but it didn't work for Eco :/



  • what model is it?



  • Laptop Model ?
    Acer Aspire V3-571G

    CPU: I5 3210M 3,1GHz
    Integrated GPU: Intel(R) HD Graphics 4000 with 128MB dedicated
    RAM: 8GB
    GPU: Nvidia GeForce GT 630M with 1GB dedicted VRAM
    OS: Windows 10



  • @Nato24 said:
    i could not find a solution on how to switch the graphics card manually. i have an alienware with similar setup ( just better cpu and gpu) but there i have a hotkey to switch it .. you might wanna contact acer support maybe and ask them how to or check the manual for your pc



  • So by the look of it if there is not a setting in the bios there is no perm fix for it you can try make custom profiles via the Nvidia control thing. And they may work for you.



  • Hah, I have exactly the same laptop :)

    In the settings for the graphic card (the GeForce one; In the german version, it is called: NVIDIA Systemsteuerung), you can tell to always use the GeForce instead... works great, unfortunately the laptop becomes very hot.

    For example, I can play Pinball Arcade in DX11 mode on high resolution without any problems. Hope ECO will get improved for GPU usage, that it will run better.



  • Usually you can right click on eco and click on what processor it runs, choose powerful instead of integrated.


Log in to reply