Server Hotfix - Strongly Advised


    This patch will wipe your world - use on new servers.

    When using google drive, click the download button at the top center in the toolbar.


    This is a hotfix which fixes a progression-breaking issue with end-game servers (specifically, servers which have access to sheet metal).
    The meteor cannot be averted without this fix.


    Extract the .zip to the directory which contains the Server.exe. If done correctly, you should receive an overwrite file prompt.

    Reboot the server and all should be good. Thanks for playing!

  • Crashes my client, every time. Reverted to original.

  • ohh ? strange should not do that. It is only adding a blueprint to an object you have from before so its obtainable

  • Somewhat interested to test this out for myself but want to wait to hear from other users and their experiences of it first.. (I too constantly keep hitting the server crash issue)

  • This could be great. On the server myself and friends are playing on we've nowhere near achieved end-game yet though, hahah. When we get there I'll let you know if it helped!

  • So...I'm eager to get back to my game but these reports of server crashes by using this hotfix has me feeling wary of trying it.

    Has anyone tried it and not had server crashes?

  • to be honest .. i cant understand how fixing a config file by adding the laser blueprint can crash the server... i think there are other issues causing that. i know somewhat how the server works ( i know c#) and i know exactly what the hotfix is doing .. so i cant see how crashes can be caused by adding just one blue print to spawning to players blue print .. the blueprint and everything is from before there.. its just a small config fix :/

  • if you open the old file and the new file you see what i mean =P

  • Gotcha, I'll try to back up the server data just in case and give it a try. Cheers.

  • make sure you dont use the x buttone to stop the server but use ctrl + c in the console .. it seems to be a bug where the server is not saving its data if its closed the wrong way :S

  • Installed the hotfix. Wiped the server. (I have a back-up.) Any ideas?

  • if you copy the backup back in does it wipe it again ? still cant believe that can wipe the server O.o.. maybe you have the save bug thing mentiont above ? if not i can send you a backup of that file i have

  • Same here, applying the hotfix resetted the map, tried to import the backup, did nothing. Even tried to mess up with the files without success. Launching the backup, without the hotfix works fine and properly load the map.

  • Indeed. Like I mentioned in one of my other threads, this hotfix creates a completely new world.
    Even though it adds nothing to the storage folder.
    Even putting the old storage folder in will give a new world.

    Tested it multiple times.

  • Ohh really? I sure nfuller is not getting any candy for a week after the holidays :p well i guess you guys are right. Thanks for testing it. I guess some data from all classes is saved inside the save files :-/

  • message from one of the devs .. thinks you also can try

    metachronism [21:34]
    so I think, if you backed up the prior storage folder, you could get it to work by

    1. back up server/storage
    2. apply the patch
    3. run the server (will kill your existing world)
    4. close server
    5. copy old storage EXCEPT for the file - leave the existing one

    might work

  • looks btw i was right actually how they save data =P .. just there was one other file breaking it =P ?

  • Does not work.
    I'll launch it again because there were a bit more errors in the CMD screen. I'll post them soon.

  • Loading worldobject...
    Loading worldobjexts finished in 71ms
    9 error(s) occurred when loading worldobjexts:
    Index was outside the bounds of the array.
    Index was outside the bounds of the array.
    Invalid integer value in the input stream.
    Index was outside the bounds of the array.
    Index was outside the bounds of the array.
    Index was outside the bounds of the array.
    Invalid integer value in the input stream.
    Invalid integer value in the input stream.
    Index was outside the bounds of the array.

    Errors loading world objects.
    Intializing WorldObjextManager finished in 94034 ms

    And the rest of the launch proceeds as normal.

  • ok thanks for testing =)

  • You're welcome.

Log in to reply