Completely new to Linux need help.

  • I am having a problem running Eco in Linux. I haven't found any help on google or the forum and what I did find did not work for me so far. I am absolutely new to Linux however I have a Chromebook in which I installed crouton and downloaded the Linux version of Eco. I have set permissions to execute however when I do it says "cannot execute binary file: Exec format error" This is the only laptop I have and would love to play while not being restrained to my desktop.

  • Howdy! i dont thing chome OS supports to much beside web applications. I am not sure but i think chrome books, at least the 2 reference models i checked are even powerfull enought and dont meed the minimum system requirements. I only did 5 minutes checking on this but it seems chromebooks use a version of android actually and dont support lots of the standart linux apps even ( i might be wrong here )

  • I'm aware that basically nothing is supported on the Chrome Os I enabled the developers mode and installed linux and everything is great with it and I'm able to play some window based games however I cannot get the linux to run the linux version of Eco is my current situation haha

  • Android is some kind of linux, but the binary format is totally different.

    From what i read, you need to install linux with crouton and then you can use linux apps with it. You cannot run linux apps directly in ChromeOS.

  • I have linux installed with crouton. Its running alongside ChromOS as one cannot completely get rid of ChromeOS. I do have linux apps that I use but The Eco game just doesn't work with it. Basically can't run much of anything on ChromeOS which was why I had gotten linux on it and used Linux instead. But I only use linux for basic school stuff so I wasn't sure if there was anything that could be done.

  • Mhh its really hard to say. Not sure what the issue could be . Like missing drivers or other thinks :(

  • And you have mono installed too? And check if you need 32 or 64 bit.

  • I do not have mono how do you yet mono I asked a friend at college tonight and they said to try mono as well but I'm not sure how to download and install that.

  • @Tangster97 said:

    I do not have mono how do you yet mono I asked a friend at college tonight and they said to try mono as well but I'm not sure how to download and install that.

  • if you are using Ubuntu Linux, open the Ubuntu Software Center and search for "Mono Runtime" and press install

  • Still no luck.

  • At this time because of the .NET version that ECO 5.5.1 is compiled with mono is not working. They dropped back a .Net version in 5.5.2 to help with that and that is a version that mono should work with. Right now the best you can do to get running on linux is to try mono. The server is really only supported for windows and while the dev's would like to see it run on linux until a new release of .NET it won't be able to run natively and will require mono - which is apparently an issue at times. The client is supported for windows, mac and linux, but server is only currently supported for windows.

  • Can't seem to get it to work. Thanks for everyone's help I guess i will just stick to my desktop for now. Time to save up for a new laptop anyways. Thanks for everything. I can't wait to witness the final outcome and release of this game.

  • Correct. I have tried to compile it with MONO, as well as WINE. Neither work with the current 5.5.4 version.

    I did finally get around to sending an email with my exact error message in the MONO execution. The error is the EXACT same when trying to compile with WINE so... the .net core dependencies don't seem to be "sticking" with the rollback.

    Hope to see LINUX support again. Would be fantastic.

Log in to reply