Alpha 5.5 Stable version Bugs



  • The Mouse Sensitivity option in the menu has a typo, "Mouse Sensitivty"



  • My Kiln just ran out of fuel, but the status tab still shows The green checkmark and "Fueled".



  • Elk Wellington has a weight of 0.00 in game.
    temp.jpg



  • @Pradoxzon said:

    Elk Wellington has a weight of 0.00 in game.

    Hotpatch to Mods\AutoGen\Food
    ElkWellington.cs



  • On our server the wood carts keep disappearing. Example: I left it at 77,78,58 when I logged out last night, but it is not there anymore. When I check the deed it shows it as being at 1078, 1059.

    Pam in Discord told me to report it here because this was supposed to be fixed in 5.5. The server was created with 5.5 and we've updated to 5.5.1 yesterday. This issue has occurred in both versions for us.



  • Heres is a bug well to avoid......i was standing at 1999,0,1999 and i tried to claim a land after the 0,0,0 point and it bought land outside my map perimeters now the server thinks i own 2 extra plots that dont exist



  • i basically had to unclaim the land and hide the deed and reclaim the land with a new one but i still have a deed now thats pointless but it says i own plots 2002,707 and plots 2002,712 and my map is 2000x2000



  • make sure you are standing in the plot you want to claim when you claim it



  • A resource cyclic dependency deadlock exists for [Pumpjack].

    See Attached diagram:
    pumpjack_cyclic_depend.png



  • well considering oil is finite how long will it last???



  • Not sure what actually happened but we had some random tailings appear and pollute some areas out of nowhere.

    I've noticed the timer going crazy for charcoal fuel, but not for log fuel, especially in the bloomery.

    Several trees I've felled have fallen onto a small outcropping/ledge and become stuck. Even after splitting the tree into small logs, the pieces didn't fall to the ground.

    Also the sliding on tables & invisible people.



  • Flour's description is bugged.
    temp.png



  • Camas Bulb Bake's description has a typo; "An" should be "A".
    temp.png



  • Temporary workaround to the Pumpjack issue reported above. Details in the zipped readme.txt.
    5.5_pumpjack_resource_fix.zip



  • @Karellen said:

    Is there a change log for 5.5 - doesn't seem to work using mono on linux anymore and thought that might give some reasons why

    @MGrand3 said:

    @Karellen I haven't seen a proper changelog yet, but if you read through the Discord there was someone with the same issue earlier. Not sure what became of that but might be worth a shot.

    I found the conversation you were referring to and I've been having the same issue. (The client seems to be fine, but the server won't launch.) It appears to be related to bundling some of the libraries in the executable. Hopefully the switch to the .net core will resolve the problems we've been having with mono. Linux may be sitting the bench for a while, which is disappointing but understandable. These things can happen when making big changes that take time to implement. Although the devs seem to be aware of the problem, I'll post the error I'm getting here for confirmation and visibility (same results observed with 0.5.5.1):

    Unhandled Exception:
    System.IO.FileNotFoundException: Could not load file or assembly 'Eco.Shared, Version=0.5.5.2, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'Eco.Shared, Version=0.5.5.2, Culture=neutral, PublicKeyToken=null'
    [ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly 'Eco.Shared, Version=0.5.5.2, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
    File name: 'Eco.Shared, Version=0.5.5.2, Culture=neutral, PublicKeyToken=null'



  • Has anyone got Contracts working We are testing and it does not seem to work



  • Anyone seen this:

    1. Kill Fox.
    2. Attempt to pick up Fox
    3. Get message Fox was already harvested.
    4. Fox disappears

    ?

    I was alone on the server and I know no one snagged it after I killed it as I was very close to the fox and would have noticed if anyone else was between me and him.

    I have now had this happen every time I kill a fox. Just do steps 1-2 and get 3 and 4 :)



  • the fox thing i seen it once on an elk but i just thought i was too late getting to it
    didnt think too much of it



  • The bug with foxes is a known issue and should be fixed either in the new 5.5.2-staging or in the stable 5.5.2 build when that arrives.



  • Thank you MGrand3


Log in to reply