Trouble Running Public Game

  • Issue

    Cannot connect to server from outside network

    Firstly I should say that I have had success before on another device with exact same specs as server

    • I recently started a server to play with friends. I've port forwarded, set to public, went into firewall and also turned off bitdefender. After all this it doesn't allow me to connect on an outside device. Local works however.

  • there is a network troubleshoot section there .. read it .. pretty sure the answer is somewhere there .. if not you need to find out where on your network it stops

  • Problem was solved thank you for the swift reply.


  • I am having the same issues, but the troubleshooting portion is not helping me out.

    The server runs fine. I can join it from localhost. Same for the webservice.
    I think it is still a firewall issue since my smartphone cannot access the webservice while connected to the same wifi.
    The firewall is definitely set to All. I found it strange that it was set to private by default.


    Any help would be greatly appreciated.

  • Try opening Ports directly 3000/3001 TCP in and out

  • I have tried this now and that did not solve it.

  • Did you open the Ports in your Router firewall`?

  • My router is setup correctly.
    All my other games work fine when I host servers.
    Not that it should matter, because my router doesn't really come into effect when I try to connect with my smartphone on the same wifi.

  • Can you connect in game, by adding a server via the WebServer port? I have an issue where I cannot join my dedicated server via the GameServer port (3000), but if I type in the WebServer port (3001) I can join the server just fine. Its the strangest thing...

  • Quote Ryve:
    The server runs fine. I can join it from localhost. Same for the webservice.

    No one can connect from external IP, but the problem is not in my port forwarding.
    I also cannot connect to the webserve from my smartphone on the same wifi, which doesn't go through port forwarding.
    It has to be a firewall/eco setting issue, but I have no idea how.
    I used to host an eco server and it ran fine, but something has changed on eco's end since then and now it doesn't work.

  • There is an odd bug i have seen. ! When you add the port via giving the application path then it will not work .You have to specify the ports directly like in my guide to make it work. That's because windows firewall and antivirus and 3rd party firewalls dont see the web port that is been opened after the server starts and still keep blocking them. While if you login via lan you will get access to the game via the discovery udp packages

  • Do you mean by adding a new rule where it doesn't specify which .exe is for?
    I tried that as well like in your guide, but that didn't solve the problem.

  • The guide that i linked shows how to set up a server including ports. It also has a small section about troubleshooting network issues. You need to find out where the issue happens .. is it the server ports that are causing the issue or is it your router? Easiest way to test that is with a mobile phone by connecting via wifi first and see if you can get anything from the law page and then redoing that via mobile 3g network

  • Like I said before.
    It is not a port issue since I can't even access the law page from my mobile on the same wifi, let alone via mobile network.
    I can access it on localhost, so the server is running correctly.
    I went through your entire guide twice including the troubleshooting section before posting here.
    Nothing solved it.

    I have hosted a working server before.
    The only thing that has changed is that it is a newer version of the Eco server that has made some considerable changes on the network front with alpha 4.

    The server is set to public and ports are still the default ones.
    Even though my firewall shouldn't block them(like in the past) I made a new rule, both inbound and outbound just to be sure, with full access open on port 3000-3001.

  • When you deactivate the firewall its working ?

  • ports.jpg

  • @Kampfkarnickel
    Interesting, I haven't tried completely disabling my firewall. I will try that when I get home.
    Thanks for the idea.

    And yes, my rule looks exactly like yours does.

  • My server is still not accessible even when I completely turn off my firewall.
    So, my firewall settings are not the problem here.

    What else could it be?

  • 2 thinks that could cause the issue i would think of ..

    1. Issue with your router ? setup wrong
    2. You have some form of ipv6 tunnel causing trouble.

    You need to figure out if you can get access to your server law page via your phone while connected to your wifi and without being connect to your wifi.

    there is a short troubleshoot guide you should follow

  • An update:
    The troubleshooting has been a lot harder then it needed to be because for some reason the web service crashes chrome on my cellphone.
    This is apparently why I couldn't connect to it from that device.
    I have tried with a different device and I can actually connect to the web service through port 3001 from a device outside my local network.

    The server is however still offline for everyone else.
    The only thing left in the trouble shooting guide is to make sure that the server isn't mistakenly private.
    To make sure no one asks me to go check that part of the guide I have the following: