100% Object loading Bug workaround

  • Howdy What error do you get . I know there are allot of whitelist servers out there where you need to apply to get into them but it should tell you if you are not on the whitelist

  • @NoBlackThunder I get stuck at "Loading Objects 100%". That's all. Was never able to join any public server since I got the game yesterday.

    I tried the lowest possible game setting, talked to some of the server admins to help me. Nothing worked. Getting stuck.

  • ahh if your view range is to low ( old rare ... very rare bug) you need turn up the view range .. for some odd reasons it might be 0 or less though there was once a fix for that issue i think

  • @NoBlackThunder If by range you mean visibility range, I did try to set it to max, minimum and in the middle. No luck.

  • @RhanCandia
    Hi there, the bug you have i've seen it before with another user of our communmity, its cause is stil uknown to us but, after trying many things he managed to make his game work again, its not server related but fully client,
    Try switching between full screen and windowd mode, and play a litle with the graphic setings, i cant give a exact fix as the cause is so unclear stil but some mixin of seting like that fixed it for him.

  • @Zaskersky Hi there. I already tried windowed and full screen. Played with settings and all that. Still no go.

    Actually, I was able to go into GreenLeaf only twice.

    1. After I deleted the game folder, %temp% contents, AppData/LocalLow/StrangeLoopGames and AppData/Roaming/.mono

    2. Freshly booted PC. Went to game in windowed mode and connected to GreenLeaf right away.

    But on both instace, after a few minutes of walking, I get into a void of space where no chunks are generated then I get disconnected.

    I also suspect it may have something to do with my ISP. My question is ... how does joining a server work, network-wise.
    Do I connect directly to the server or is there another layer of auth before checking into the server?

    I'll try to traceroute a server later to see if there's an anomaly between me and the server. I'll show you the results later when I get home.

  • @RhanCandia
    From what your telling me it does sounds like a conection related problem, and yes i believe the server does have another layer of conecting.
    As a server hase a option to authenticate a player acount and like 95% of all server hase that enabled i asume that it first conects to strange look authentication server, and then back to the game server.

    To be 100% sure its conection related, and not cause of hardware conflicts, fps, or any thing in that direction there is 1 thing you still can test if you havent already, go to your eco acount on the website and download the server file, its all preconfiged only thing you have to do is press extract, and run it wait a few minits till it rendered a world, And then join your own server showing up under Lan in your eco game client, to see if it runs longer then a few minits there.

  • @Zaskersky

    I've tried running a local server and I was able to play consistently. No disconnects, no issues whatsoever. So it must be a network issue then.

    Is it really the strange loop authentication layer? Why get stuck on "Loading Objects 100%"? The admin of GreenLeaf once told me on discord that they see me on the game while I am stuck at "Loading Objects 100%".

    Does the game do logging? Should I send you the logs?

  • From what i can see it seems you keep getting some how outsite of the world borders .. if you are outside of the world border you cant join the server again until some one resets your position .. though if you getting this issue over and over again than that would sort that there is ether way something wrong with the server, a bug we dont know about or some odd network issue causing to send some corrupted data .. not sure

  • @NoBlackThunder I've been pulled / teleported by an admin a dozen time and I still get stuck at "Loading Objects 100%". I hope we can figure this out.

  • @RhanCandia As an Admin who has done this a lot, it could be as simple as the Admin not typing in your name correctly. First time I did it, I did the names lower case. The lady I was teleporting had a few caps in her name and didn't think it was really necessary to do that.The Command does not send the client an error message if we screw up. That may be the case for you(MAYBE, just trying to help ya!)

  • @MasterWho Hi there. I'm on a discord chat with the server admin of GreenLeaf and I am pretty sure he didn't misspell my username. I'm still leaning towards the idea that this is a network issue.

    I've had a problem connecting to Overwatch before because of my ISP. Tracerouting and reverse traceroute shows me drops even before I reach the blizzard servers (but is fixed now). If that's the case, I can't think of a way to fix this other than to switch providers.

Log in to reply