Game download



  • I gust got game and download can not get it to start I use window 10



  • Also Win 10 and works just fine.



  • Make sure you got .NET installed.



  • It might be a dum question from me. But you did extract the client files from the zip file you downloaded right ? and you did try to start the eco.exe file?



  • I am having the same problem. I have the .NET framework and core installed yet when I try to start the game (windowed or fullscreen) it goes straight to a blue screen with the ECO cursor and nothing. I have tried hitting ESC, Space, and Enter to no avail.



  • I have occasionally see this myself (running dev builds even.) I found that if I switched away and back using Alt-Tab it would then work fine. Give that a shot. I have no idea why that had any effect.



  • No such luck Alt-Tabing Chronos. The game worked fine the first time I ran it but after quitting the game would only give me this screen. I started ECO before leaving for a haircut and when I came back it was still the same thing. UPDATE: Found that I have to extract the zip file package to different locations every time I want to try and play. ECOscreen.jpg



  • @billder You should never have given your computer a haircut :E



  • I have the same problem, the only way to solve this is to delete the ECO unzipped file and Unzip it again.
    I am using ALPHA 64bit 5.3
    My computer has Intel HD Graphicx 5600 (CPU integrated GPU)
    My native screen resolution is 2560x1920
    I play in 1280x700

    I thing the game just saves something on the folder after you play once.
    This new saved file maybe interacts badly with resolution etc..

    Whenever you quit a server this blue screen appears for some milliseconds before you get to the server list menu.


Log in to reply