Client Bug - Crash upon attaching plot

  • When attempting to attach a new plot to my deed I am booted from the server with an error message:
    My initial plot was fine, it seems to be when trying to add a subsequent plot to the deed that causes this issue. I have rejoined and tried several times and the same problem occurs. Sorry if this is a known issue, I did have a poke about and couldn't find anything similar.

    Client: Alpha 0.5.3

  • That's a new issue.
    is it always on the same spot? can you reproduce it on another spot? what i would like here also is your file from the server and the coordinates where that issue happens

  • Hey, I'll get on this as soon as I get a chance. I don't actually know who runs the server but I'll see if I can get a copy of the log for you.

  • @NoBlackThunder
    I tried this again on a different server. Looks like any time I try to use the "Attach Current Plot" from the DeedItem item I get booted along with the same error message.

    I started a server to test the problem locally and this was the error the server returned:

    Here is the file as well:

  • I think part of the problem was me misjudging the manner in which Claim Flags work. I think I was under the assumption that a claim flag covered a larger area than it does, thus when attempting to add a plot to my deed the game tried to look for a claim, found none and crashed. This brings up the question of whether or not it would be worth having some sort of visual cue telling you how big an area your Claim Flag will cover, and to bring up a visual representation (perhaps just highlighted blocks) when you have your Claim Flag selected so you can see where best to place them.

  • I received this crash yesterday performing the same task, attaching plots.

  • @ChillBilly Try checking whether or not you are actually attaching a plot that has been flagged using the claim flags. I think that's the problem I was having. Still, it shouldn't crash the game!

  • @evanpage I am not exactly sure, but I think it actually crashed the server too. I didn't try it again, but I intend on testing this on my own test server to try and further help the devs.

  • It maybe happened yesterday in a server whene i claim a zone of 100 block, the server was offline for about a minute and then the server restart without the structure of all player but i have the same inventory and skills