cant get server to show online



  • followed the guide, routers ports are opened. i can use the main site to view laws, yet i still cant get it to pop up or if i do cant connect to it, says connection refused. router i got it port fowards tcp 3000-3001 did the firewall inbound, allowed it all 3 checked, named it. yet, when i plug my ethernet in it appears on the list, can log into it, i unplug it , nope. also admin commands wont work, actually any command besides unstuck wont work again that is setup same way guides shows it and pingperfect. i keep getting a message saying command not found. i have no antivirus, i disabled windows defender, even killed the firewall at one point, it simply wont pop up and when i set it to private, my names on the white list, yet you guessed it im denied entry claiming im not on the list. so those of you that are having issues like me and have gotten windows 10 to place nice, please let me know or if the devs got an idea whats going on, i tried it on my desktop, but i think that needs a os reinstall because server list wont even show on it besides lan and the server works via lan when i set it up there, but again not on the list. really wondering whats blocking this from working. i get no errors ethier. so i came here hoping someone can help me figure this out ( also did all the same on the desktop and nuffin worked, even reinstalled the ethernet drivers etc and reset the firewall) thanks for any and all help.



  • Howdy .. you have to explain this a bit better. have issue following if you can connect or not even. If you cant connect to your own server as an example how can you use the unstuck command?

    Can you please explain it a bit better? Thanks ! =)



  • i can connect to it via lan so i have been using, but it refuses to appear on the game server list and the admin commands refuse to work i keep getting commands not found. when i connect my ethernet cable it shows up in the list and sometimes i can connect to it, but admin commands still will not work. Now when i remove my ethernet cable and use only wifi it will not appear in the list. now it does come up for Lan which is local play, but cant for public access. my friend bought me this game and its really fun, would love to be able to play the game with him, but i got this issue and the admin commands issue. this is how i have it setup

    {
    "$id": "1",
    "RequireAuthentication": true,
    "AllowDebugCalls": true,
    "PrivateServer": false,
    "WhiteList": {
    "$id": "2",
    "System.String": {
    "$type": "System.Collections.Generic.List1[[System.String, mscorlib]], mscorlib", "$values": [ "fatboy21008" ] } }, "BlackList": { "$id": "3", "System.String": { "$type": "System.Collections.Generic.List1[[System.String, mscorlib]], mscorlib",
    "$values": []
    }
    },
    "Admins": {
    "$id": "4",
    "System.String": {
    "$type": "System.Collections.Generic.List`1[[System.String, mscorlib]], mscorlib",
    "$values": [
    "fatboy21008"
    ]
    }
    },
    "MaxSlots": -1
    }

    as you can see i have it setup same way you all have it. yet it wont work, the whitelist wont work ethier. when i set the server to private it says my names not on the list when it really is. im not sure whats wrong. the router is port forwarded tcp 3000-3001 the game appears when i check the laws. but simply wont appear on the public list. windows firewall i created a new rule, opened those ports 3000-3001 allowed the connect, checked domain-private and public, named and saved it. there is no other firewall, no antivirus besides windows defender and i disabled that. i am very smart with computers and this sort of stuff, but this is the first time i am completely stumped. apperciate the help.



  • i tried older versions, same issue, i dont get whats wrong with it, i followed the guide exact, everything is how its suppose to be, yet wont appear in the list and admin commands wont work, actually i think most of the USERs.cs file doesnt work or least seems that way besides setting the server private



  • tryin everything even changin ports, my heads ready to implode



  • i got admin working finally, however still cant get it to appear in the public server listings





  • if you are running windows you can use the server GUI to configure your server instead of the config files



  • that guide you listed i have already done and it does not work i can only access my server via lan, nothing else i do seems to work to get it to come up on the server lists for public acccess



  • The guide has a how to check where the issue is thing at the bottom .. also if you host from your home you need to check how your router is set up .. because if you have DS-Lite tunnel in your router , you will be unable to host a server



  • well i did check it and im using a comcast cable modem that has a built in wifi. there is no ds lite tunnel in it that im aware of.



  • you have to check your wan connections. if not you have to go trough the check and see where the issue is . if its your router and you say you have forwarded the right ports then its hard to help there, since i dont know how your router works



  • http://www.bestbuy.com/site/xfinity-arris-touchstone-docsis-3-0-cable-modem-and-wireless-router-with-telephony-adapter-black/9082028.p?skuId=9082028&ref=212&loc=1&ksid=00fa4720-baf5-4419-8dbd-f14845e62f0e&ksprof_id=401&ksaffcode=pg112521&ksdevice=c&lsft=ref:212,loc:2

    not sure if that helps but thats my modem, seting up the ports was simple, however that momen or mb windows 10 is being angry and wont let me get my server to appear on public lists



  • yea most of the modem features are controlled by your ISP .. I recommend giving them a call and asking them for help i suspect that the issue is there unless you have forgotten to set the setting "Public server" under network / conf" to true



  • @fatboy21008 how did you get admin working please help because i cant get it to work



  • well when you log in, look at the bottom left side of the screen that says logged in as, make sure its typed like that and its capses sensitive, appearently i didnt have the f capped lol. everything works like a champ now, though careful with leveling, i dont know how it works too well and i killed my server cause of it lol. luckally i got back ups



  • @fatboy21008 still says command not found and i did everything right what am i doing wrong



  • for me it was simple, game name is Fatboy21008 i was puting it as fatboy21008 that f had to be F for it to work other then that i have no idea whats going on with it, im still trying to figure out why i cant make the game appear on the server lists, even with all firewalls and routers firewall off, i get nuffin. besides lan play, im stumped at this point. kinda want a copy of pingperfects server to see if it would work on mine, but i donno, this is the first game if ya this much issue runing a server for the public. mb itll sort its self one day i donno.


Log in to reply