Current Alpha 5 Test Build [PC client only]

  • "Just downloaded the latest version, shows alpha 0.5.0 master-ab890b67 in the menu, and it seems like I'm not able to place stuff when grass or other plants grows on top of a block. New blocks don't replace the item growing on normal grass blocks. So I have to dig out the blocks so the growing item disappear before I can place down log blocks.

    Is this intentional or something that can be described as a bug?"

    As they try to do this game a realsitc as possible it is intentional and not a bug =)

    And the Days displayed in the Server browser are the realtime days not the ingame days =)

  • Is it normal after setting up the server on mono, after some time most of the world plants appear dead? The big majority of my server is trees with dead plants, and specific locations where they live.

    Is this a generation issue where populations massively change after their generation?

  • @GeneralZOCK I guess that makes sense, just was a bit weird that it wasn't enough to use the scythe to clear the block.. :) But it sometimes works when emptying the shovel on top of grass or plants and sometime not.

    But I have another issue. I'm not able to collect my newly made wood cart from the Wainwright Table. I've emptied out my inventory completely, backpack and "quickbar" and still it weighs 5kg too much.. Is there a way to "buff" my weight limit that I've not found yet?

  • Its not intentional, I'm fixing it now currently.

  • @perry
    Maybe try to put the cart in the Carrying hotbar slot =)

  • @GeneralZOCK
    Oh, I've tried that, can't place it in that slot apparently. Even tried cheating it into my inventory with the give command which didn't help either.

  • You can try using the command /unrestrict to remove all weight restrictions from yourself.

  • @craig.jong Thanks, that helped.. :)

    And tnx for the fix in the last update with the "growing" blocks refusing to let us place down logs and other blocks. Just updated my client and server and so far so good. Still building my treehouse so I have to get a bit further before I can tell if the weight issue has been addressed or not. Btw it wouldn't hurt to update the top post with the current buildID.. ;P hehe.. I track the update process by checking for the version on the Dev Server, so I don't have to see that the top post is updated but it might help others, unless you post it else where that is.

  • Is there a way to craft the things that requires Pitch without cheating in the pitchItem? Like connecting the different Pitch types with the pitchItem so that f.ex Mortared Stone can be crafted by having Masonry Pitch, Charred Pitch or Wheat Pitch in inventory or storage?

    I guess this issue is connected to this:

  • @perry

    you can craft items using the other Pitch items sure, just did it myself a few minutes ago =)

  • @GeneralZOCK That's strange, I have both Charred Pitch and Masonry Pitch in my inventory and I'm not able to craft Mortared stone unless I give my self PitchItem, playing with the latest version available from the onedrive URL's on top of this topic. 0.5.0 master-c98502c9, same version as the SLG Debug server is running with.

  • we are at 5.3 already for the pre-released version. you can download that from your account page

  • I think that's more like Alpha 5 pre 3, the OneDrive URL's on top of this topic is a lot newer than 5.3 in the download list as far as I know since it's refered to as Alpha 5 RC in the server list and contains a lot of fixes done after "5.3".

  • Sorry I am traveling atm but will update the post once I'm at a better pc. Thanks for testing it so far though! I will have our tech tree designer look at the pitch issue.

  • @Metachronism No problem, I'm just posting the issues I see and find on my way.

    I'm wondering if anyone else is having issues placing for example a kiln? I get kicked out once I place one with the error Duplicate Components are not supported. I did get the same error when I tried placing a powered cart as well I think, but firstly I thought it might be because I cheated it in and didn't have the necessary skills to use it, but this kind of makes me believe that it might be because I placed it on top of some stone road blocks which in a way occupies the block above so it "thinks" it have to replace those blocks as well. Might have to retry that later today.

    --BEGIN DUMP--
    Dump Time
    11/23/2016 08:30:45

    System.InvalidOperationException: Duplicate components are not supported.
    at Eco.Gameplay.Objects.WorldObject.AddComponent[T](Func`1 makeComponent)
    at Eco.Mods.TechTree.KilnObject.OnCreate()
    at Eco.Gameplay.Objects.WorldObject.Add(WorldObject worldObject, Player creator, Nullable`1 position, Nullable`1 rotation)
    at Eco.Gameplay.Objects.WorldObject.TryToAdd(Type worldObjectType, Player creator, Nullable`1 position, Nullable`1 rotation, Boolean checkOccupancy)
    at Eco.Gameplay.Objects.WorldObjectManager.HandleAttemptPlace(Player player, WorldObjectItem item, Vector3i pos, Quaternion rot)
    at Eco.Gameplay.Items.WorldObjectItem.<>c__DisplayClass10_0.<OnActRight>b__0(BSONObject x)
    at Eco.Shared.Networking.RPCManager.HandleQueryResponse(BSONObject bson)
    at Eco.Shared.Networking.NetPort.ProcessBuffer(Int64 maxMilliseconds)
    at Eco.Shared.Networking.NetPort.Update(Int64 maxMilliseconds)
    at Eco.Plugins.Networking.Clients.Client.<.ctor>b__49_0()

    --END DUMP--

    From what I see it complains about another block occupying the space the Kiln is placed on but I have at least one block of space free on each four sides of Kiln so that it shouldn't be trying to replace any blocks. Unless that's where my last wood cart vanished that is, so that it in the "world file" still is at the same location but invisible to me in the client for some reason. I do have an invisible dirt ramp after I picked it back up with the hammer, not able to place any blocks in the same place as that one was earlier.

    Is there a way to enable a view to see occupied blocks in the game? Like a hidden admin debug command of sorts?

    Update: Did a test where I filled the entire room with wood logs just to see if there was any blocks I wasn't allowed to put any and I was allowed to put blocks everywhere. So that shouldn't be the issue.

    edit: the code block didn't quite do it's job there, so just added it to all the lines of the dump..

  • Are there any news on the ALpha 5 release atm ?

    Cuz the SLG Debug Server runs the Alpha 5 RC fot about one week now and RC stands for Release Client if i´m right :P

    So it would be nice the get some new input, because the server me and my freinds recently played on and where we almost researched the Laser thing got wiped and for reason of that we want to wait until alpha 5 gets thrown out :P

    But we dont want to wait so long haha =D

    Greetings :P

  • So... Anyone can get Eco for free?

  • @Cute-Little-Froggy said:

    So... Anyone can get Eco for free?

    You still need an account to login with.

  • @GeneralZOCK Should be early this coming week.

  • @Metachronism

    That are really good news =)

Log in to reply