Alpha 5 Bugs/quarks

  • *Fixed think the 3 main issues here are: you cant join without adjusting the view distance slider, can't kill animals, and the excess lag that is now here probably due to the animals. the rest is kind of more looks and stuff which wouldnt really stop someone from playing.

    This list is not longer relevant! these were for 5.0 v1 only. i have not tested the other versions. I am no longer updating this list

    side note: this was just a quick list i threw together for 5.0v1 if there is anything not right let me know in a PM and i can change it. i could very well be wrong :)

    • world is white on load up. everything looks like snow!

    • when picking up wood it does not show the image right away all the time

    *Fixed i went from being able to play on max setting with good frames to low settings with lower frames. optimization you will probably work out and not a bug just worth noting. probably due to to many animals?

    • Fixed Can't kill animals with axe or bow. you already stated you would get it fixed tomorrow but just noting it here.

    • Fixed cant get meat at all

    • audio setting don't stay where you put them. i hear you can try deleting registry settings.

    • Shift + Click on split stack does not work correctly. it allows the slider but does not allow you to press "ok" can hit "cancel"

    • tools on other players backpacks are purple!

    • while walking around i found the end of the world and fell untill the land finally loaded in.

    • some tiles with water in it on the map will turn the whole tile blue. not all but a lot even though there is only water on a small portion. scrolling in seems to make it go away but looks goofy slightly zoomed out.

    • I'm standing in some water that on the map it doesn't show it as water just sand in certain locations

    • huckleberries use to have its own seed icon now it shares the same icon as the berry. i like you made the wheat seed have its own icon. i know we talked about how a berry is the seed but if we are to have separate items they should have separate pictures too maybe.

    • Server went down at about 12:13 AM PST not sure if crash or you guys brought it down.

    • water falls are full of holes.

    • Fixed orientation of tools in the avatar panel is a bit off.

    • certain sized logs can not be picked up which mean it must be 6 or more but when cutting it in half you get two 2 pieces which you can pick up at the same time.

    • prickly pear population went from 0 to 2. maybe cause by there being no areas worthy to having some worthy prickly pear locations after time.

    • when scrolling in a workbench if it is over the map it scrolls there too.

    • This was in A4 as well, but you can put items into a container or bench if you stand outside your house where it is located.

    • sometimes wood vanishes when placing it to fast and while its having a lag spike.

    • Fixed i notice animals load for a far distance even with the view distance turned down all the way. makes for weird landscape of hundreds of floating animals

    • was not able to craft a certain amount of food even though i have enough materials. i think it is taking into account my efficiency on the order screen but not when you craft and says you don't have enough materials.

    • says the 4x4 area for planting wheat is over populated with 10 plants competing. no plants all around even cut the common grass.

    • if you do it right you can pick up 2 dirt blocks at once some times.

    • when you get wood from a container or at least the workbench with the axe it says "unspecified reason" in chat. nothing bad happens just it says that.

    • multiple people but not myself have claimed to have getting an error about full backpack when it was not.

    • I found a small bunch grass plant hardly grown and i can get unlimited bunch grass seeds from it.

    • was transferring a bunch of berries to my fire and it kicked me out and said no matching segment or something like this,

    • need "cooking" skill to unlock campfire but the "campfire cooking" skill is under survival. makes no sense?

    *30% mature cedar tree yields 132 wood. seems off

    • if you don't close your chest or workbench screen you can walk as far away as you want and move the items around long distance easy.

    • no deed for cart?

    • after letting go of a cart it still shows me the road efficiency amount.

  • How about keeping the world save in the old state with and stuff again? Why the hell did you have to put it into one file? Any way i can split them using programs? Or is there a purchasable version without merged storage files available? Thx for reply @ecodevs

  • I'll post here the bugs I found in the A5 :

    If you eat something which is in the toolbar by right-clicking when it is selected, you will it eat twice and its number will not decrease. It doesn't do so if you right click on the toolbar.

    Very laggy (I know you said it but I tried with a 0.25km² map and it is still the same) compared to A4 and for the same settings.

    The world seems overcrowded with animals, this might be causing the lag as there is so much animals to show. (I tried to mess with the generation values in the server settings but it only makes it crash.)

    When I try to open the minimap, I get a few seconds of freeze, the window show up but no minimap inside.

    The reflection of the water is blinking.

    • The farmer table have the skin of the butcher table, on the miniature and in the world

    This is what I found for now

  • Guys the lag, try messing with the sliders, and take minimap detail to the lowest settings.

    Wheat seed does not stack automatically.
    Beet seed does not stack automatically.
    Corn seed does not stack automatically.
    I'm NOT near water, but I can hear water, sounds like ocean waves on the sand, not the waterfall sounds.

    How much, if any, is the farming affected at this point by the stats in the seed description. I am currently standing in a location, beet seed says 0% growth rate, bean seed says 0% growth rate, but I just harvested beet and been a few tiles apart from where I am standing. So, does 0% growth rate mean it wont grow in that location? If so, its broken.

    Server went down:
    6:11 CST

    When inventory is full, you learn a skill that gives you an item IE. chest, ax, shovel, it will crash the client, upon relogging, you have the skill, but no item. Should be a checksum for inventory space before applying the skill, or have a temporary overflow slot, or make it go into your carry slot.

  • I had all settings bottomed out. Helped with the lag a lot but could probably worked on as I was able to have max settings. Now low. Also the wheat seeds. I did not have that problem. There is a bug/quark where if it's in the back pack and you pick up more it goes to hotbar.

  • I guess we won't be seeing that update for a few days. le sad face

  • It feels like every tooltip was removed, i cannot see any nutrients of food in the campfire. They only show up after i cooked the meal. Would be nice if we could get them back.

    And all animals are on noclip, nothing can hit them.

  • the tooltip thing is quite important id say. i dont want to miss all that information.
    nutritions on food, room requirements on workbenches. when you have the actual item in your inventory you can see that information, but not while/before crafting it (tooltip in the crafting bench).
    but most importantly skill benefits! how much exactly am i getting when i level up yield or efficiency?

  • Animal collision should be fixed in the next update.

    A lot of the lag can be attributed to animals not EVER being removed, even when you move out of range of them. Hence the floating horizon of animals. The number of animals created by the simulation is also being rebalanced, though those numbers were inflated by some incorrect grass placement in a lot of cases. Both of those things are being fixed.

    The data given by the farming tool, seed tooltip, and most things that draw from world layers are giving incorrect information due to an extremely minor bug. This should also be fixed.

    No promises, but we're looking to get a fix out for those things (which are fairly major bugs) by tomorrow. I wanted to let you all know that we're fixing these bugs and we appreciate the advanced testing you guys are doing! We do read this stuff and it helps a ton when figuring out what's going wrong and what to prioritize.

    Almost forgot! Tooltips are something that I haven't looked at in a while; likely broke during some other updates that we did to skills/items/etc a while back. I'll look into it after the major bugs are fixed but it likely won't be right away.

  • Oak trees don't seem to be able to be picked up. I cut several down, chopped the tree up to the smallest piece I could before going too small to destroy it altogether and get an error;

    Inventory Full: Can not pick up 10 logs (max 5)

    It would appear that even the smallest piece of Oak is considered to be 10 logs, and goes all the way up to 26 logs is the biggest I could get in a part of the tree that was green and not yellow, which obviously gave me the same error; Inventory Full: Can not pick up 26 logs (max 5).

  • I have ferns in my 2nd slot of my inventory and when i highlight them and right click to eat them they dont come out of my inventory. Also cedar saplings seem to produces much more wood than full grown cedars

  • thanks for the reply craig-jong! just making this list for you guys. i feel like once the animal issues are fixed it will be a decent version! keep up the good work guys!

    i keep editing in more so if you keep an eye on it there might be something new

  • Not sure if its been pointed out yet, seems there are several threads with feedback about A5 testing. Perhaps one of the forum admin guys could consolidate them and start a pinned thread with A5 bug reports / feedback so they are all in one place.

    Anyway, Farmers Table looks like Butcher Table when you place it in the world.

  • there is this thread that i made and the dev actually did make a pinned thread under "general" for known bugs as well.

    i have posted what i know in both sections. if everyone sticks to these 2 threads it should be organized enough hopefully.

    also i think the butcher table is a better place holder for the farmers table then the chest model :P

  • Everyone was promised a full release on the 24th, but honestly we got a buggy mess, I understand its alpha and stuff, but they should have said a pre-alpha 5 release instead of a full release.

  • I think they tried their hardest and just couldn't make it achievable. they decided to call it a "pre-release" probably because if they called it a full release people would be mad. they are doing their best and working really hard on the next version to fix the major issues! We don't want to pressure them to much! Give them time and they will give us greatness :)

    in the mean time 4.2 works great still!

    Please though try to only report bugs in this thread

  • as much as id like a working version NOW, i think this is a good compromise. if you really want to see the new content and changes they made, then you can, but obviously it's bugged. or you can stick to alpha 4.2 and wait.
    i personally rather see the progress and help with some bugreports than have nothing released and wait another couple weeks until a fully working version. but each to their own. you cant magically throw out a bugfree version if you dont have one.
    i think being transparent here and including the community is a great move from SLG, instead of going the "sorry we have to push it another 4 weeks"-route.
    this is alpha after all, thats what i signed up for early.

  • Is anybody having issues with their alpha 5 servers not showing time moving forward at all? We are stuck at 8:00 am on day one and it's not moving forward any. Does anyone know of any remedies to help fix this? My guess its a bug in the alpha stage or something in the server config files.

  • On your server, set the TimeOfDayScale on the simulation tab to 48 (30 minute days). We frequently set this to zero for testing, and it snuck into the build that way.

  • Awesome thank you! That was a rather easy fix.

Log in to reply