Alpha 5 known issues

  • Current Version
    Alpha 5 prerelease 2 (alpha 0.5.- master-2bd86ae4)


    • Client memory usage is quite high. This is affected mostly with view distance, lower it for now if you encounter issues in the meantime

    will keep this updated as new issues are brought up

  • *Fixed think the 3 main issues here are: you cant join without adjusting the view distance slider, can't kill animals, and the excess lag that is now here probably due to the animals. the rest is kind of more looks and stuff which wouldnt really stop someone from playing.

    This list is not longer relevant! these were for 5.0 v1 only. i have not tested the other versions. I am no longer updating this list

    side note: this was just a quick list i threw together for 5.0v1 if there is anything not right let me know in a PM and i can change it. i could very well be wrong :)

    • world is white on load up. everything looks like snow!

    • when picking up wood it does not show the image right away all the time

    *Fixed i went from being able to play on max setting with good frames to low settings with lower frames. optimization you will probably work out and not a bug just worth noting. probably due to to many animals?

    • Fixed Can't kill animals with axe or bow. you already stated you would get it fixed tomorrow but just noting it here.

    • Fixed cant get meat at all

    • audio setting don't stay where you put them. i hear you can try deleting registry settings.

    • Shift + Click on split stack does not work correctly. it allows the slider but does not allow you to press "ok" can hit "cancel"

    • tools on other players backpacks are purple!

    • while walking around i found the end of the world and fell untill the land finally loaded in.

    • some tiles with water in it on the map will turn the whole tile blue. not all but a lot even though there is only water on a small portion. scrolling in seems to make it go away but looks goofy slightly zoomed out.

    • I'm standing in some water that on the map it doesn't show it as water just sand in certain locations

    • huckleberries use to have its own seed icon now it shares the same icon as the berry. i like you made the wheat seed have its own icon. i know we talked about how a berry is the seed but if we are to have separate items they should have separate pictures too maybe.

    • Server went down at about 12:13 AM PST not sure if crash or you guys brought it down.

    • water falls are full of holes.

    • Fixed orientation of tools in the avatar panel is a bit off.

    • certain sized logs can not be picked up which mean it must be 6 or more but when cutting it in half you get two 2 pieces which you can pick up at the same time.

    • prickly pear population went from 0 to 2. maybe cause by there being no areas worthy to having some worthy prickly pear locations after time.

    • when scrolling in a workbench if it is over the map it scrolls there too.

    • This was in A4 as well, but you can put items into a container or bench if you stand outside your house where it is located.

    • sometimes wood vanishes when placing it to fast and while its having a lag spike.

    • Fixed i notice animals load for a far distance even with the view distance turned down all the way. makes for weird landscape of hundreds of floating animals

    • was not able to craft a certain amount of food even though i have enough materials. i think it is taking into account my efficiency on the order screen but not when you craft and says you don't have enough materials.

    • says the 4x4 area for planting wheat is over populated with 10 plants competing. no plants all around even cut the common grass.

    • if you do it right you can pick up 2 dirt blocks at once some times.

    • when you get wood from a container or at least the workbench with the axe it says "unspecified reason" in chat. nothing bad happens just it says that.

    • multiple people but not myself have claimed to have getting an error about full backpack when it was not.

    • I found a small bunch grass plant hardly grown and i can get unlimited bunch grass seeds from it.

    • was transferring a bunch of berries to my fire and it kicked me out and said no matching segment or something like this,

    • need "cooking" skill to unlock campfire but the "campfire cooking" skill is under survival. makes no sense?

    *30% mature cedar tree yields 132 wood. seems off

    • if you don't close your chest or workbench screen you can walk as far away as you want and move the items around long distance easy.

    • no deed for cart?

    • after letting go of a cart it still shows me the road efficiency amount.

  • When decreasing the "minimap detail" setting to just below highest it turns off all the view functions. Took me ages to work out why the different minimap views weren't working - is that intended?

    I'm using a 660ti gfx card

  • I can see a fire over the top of my house even though when you are closer the fire clearly should not be that high. must be something with the curve effect. New Bitmap Image.bmp

  • Road efficiency: Grass, 0% and the cart dont move anymore, but yesterday it worked fine with 50% on Grass.

  • @pan7s said:

    New Bitmap Image.bmp

    I would have gone with "levitating mammals" as the biggest problem in that picture. ;)

    On a serious note, a big salute for compiling that giant bug list. I wish my users would do that for the software I make.

  • the animal problem is known, the animals are loaded even if the land under then is not its a view distance problem. and this is in my eyes the problem for some lag and not spawning craftingtables/chests.

  • As I've mentioned on Slack, I'm experiencing an issue whenever I trigger the "connection failed" state. The error appears on the screen but once that window is closed you're no longer presented with the server's list. The Esc menu is still available and the only solution is to quit the client and restart the game.

  • Placing store kicks you from server

  • dont know if its only the SLG server but i cant connect anymore
    "Connection Failed Caught exception: index was outside the bounds of the array."

  • @Gemji I was still logged in. Not sure. You'll have to wait for @Metachronism

  • looks like the problem solved itself, but im not sure how one think might be a restart from the server or it was because of the time i went on another server

  • Sound will not stay up where it can be heard.

  • Hey guys, thanks for these lists, they are very helpful. We are going through fixing them as fast as possible!

  • cannot get the Admin Commands to work, there is a typo giveGives ....

  • Clicking "configure" or "add server" on server list does nothing.

  • Mentioned above but clicking on 'Add Server' or 'Configure' does nothing.

    No audio despite changing the volume settings (this includes SFX and Music)

    Occasionally unable to see other players on the server

    Occasionally refreshing the server list will leave you with a blank list.

  • Strange, I do get sound and music. I didn't at first, both were set to zero. I turned them up, which IIRC had no effect. But when I restarted layer I had sound and music.

  • @Lobodemonio said:

    Lobodemonio posted about an hour ago reply quote 0
    Mentioned above but clicking on 'Add Server' or 'Configure' does nothing.

    No audio despite changing the volume settings (this includes SFX and Music)

    Occasionally unable to see other players on the server

    Occasionally refreshing the server list will leave you with a blank list.

    i think this is a read write issue with the config file .. it should be somewhere in the appdata ? maybe @Metachronism what do you think?

  • @NoBlackThunder I'm still having the issue with audio. The sounds are playing at the intro screen but despite the client audio settings the sound just wont play once actively playing. If it's server side could you let me know so I know that's the issue. I'll start a server just to tinker.

Log in to reply