Game crashing


  • Hi, guys!
    I have problems with my freshly downloaded game. I just tried it out, but every time I try to dig up some earth or stone, or cut down tree it makes all server (EcoTech and one another which is still down) to crash. Every time.

    After pressing E, few times it gives message, that ''you can't carry that'' and then all server goes down, crashes. There is also no animations for this process. Only animation I have notice was several times at very beginning while cutting fern. Only several times from all.

    After few crashes started to miss my tools - like hatchet, sickle etc. I have skill but do not have tools any more. So only thing I can do now is to walk around and make server crashes. It is not very exciting or enjoyable.


  • 13
    Posts
    2765
    Views
    Log in to reply


  • Are you running your own server locally? Or are you connecting to another one?

    When the server crashes, it will dump the log to Server/Dumps, if thats the case can you post the contents of those files here? The ecodump files are just text files.

    Can you post a screenshot of what error its giving you?



  • No, I connect to other servers.
    Here is some screenshoot. As you see the error message, actions are not having done, and tools crashes - do not changes to other, all others start to disappear or lag.
    Error1.jpg



  • Hmmm, do you somehow have 3 shovels or is that a bug? Try dragging the scythe out of the carrying slot - thats generally reserved for other items. There might be a bug with it in that slot, its the first time I've heard of this



  • I would like to do that, but now that server is down as well. :(



  • Joined this server:
    Capture.JPG

    Then did few jumps, leveled up 3 survival skills and tried to cut tree and dig soil. Slowly pressed several times action button.
    1st.JPG
    You see the time and tools I just got. I tried cutting down tree. Got some, rare and slow animations, that is all. Few times there was sound. Usually game is 95% silent for me. No music, just walking sound - that's all.

    5 min later:
    2nd.JPG

    I am really sorry to owner of this server. I tried to choose some where is less participants and no one online.



  • I have ordinary laptop with good internet speed. I am surprised that crashes not only my game, but whole server. I am not very into IT, but that seems strange to me.

    P.S. Sorry if I am not very logical - this is first time a report issues with game, just because it is not playable at all, just right after I bought it.

    Would love to try it out and help with bugs, just do not know how.



  • Next:
    Joined server at 22:51
    22.52.JPG
    Walked around in this world:
    3.JPG
    4.JPG
    Understood that nothing good will come here and disconnected at 22:54 (3 min after I logged in).
    22.54.JPG
    Server offline again.



  • Feel like cursed now. :D :)



  • Here is screenshot from EcoTech server, where I started.
    Skill points has grow up to 19 in one day, but has not tools to do anything - just hammer to destroy something and showel to crush server. Other tools has disappeared, as well as workbench which was in this place when I logged in last time. no tools.JPG



  • Next case:
    Joined this server at 23.20
    10.JPG
    That is how it looked like at 23.21:
    23.21.JPG
    Gathered few berries. Did not had any animation for process. Just after a while bush disappeared and berries was in inventory.

    Then at 23.24 tried to cut down tree. After many tries, outline of tree for cutting did not glowed, just tiles on the ground, there was no single animation for hatchet move and after a short moment server went down.
    23.24.JPG
    Thats how it looked like in 23.25
    wtf.JPG

    I hope someone has a good advice or if not, I would like to have a refund. I am really sad, because I really love the concept of this game, I wish all the best luck to developers and would love to play it. Right now, for me it is not possible to play or enjoy it.



  • I think you may be confusing the 'carrying' slot. Basically don't put any tools there - in order to use a tool, it needs to be in one of the toolbar slots instead. Only large items that are picked up, such as dirt, logs, will go in that slot and it will happen automatically. We don't really have a tutorial so none of this is your fault, it can be very confusing at the start.

    for axe swinging, you need to click and hold instead of just clicking once. With no skills, chopping a tree will take 10 hits to bring down.

    For harvesting plants, you need to highlight the ground underneath the plant and press 'E'. Some plants require the scythe to harvest however. Again with the scythe, you need to click and hold to continue the action.

    I don't really know about the servers you are trying to join. It could be that the host keeps shutting down the server, taking it offline. StrangeLoops debug server should be running continously.



  • Ohh, thank you so much!! It seems that was the problem. Now it is going properly for now. :) :)
    I didnot have an idea that this box is for something else. :)
    I will try for longer time, but it seems that will fix the problem. :)


13
Posts
2765
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!