Server Hosting Problems, Windows Server2012 R2


  • Hello,
    How to get the Server running without giving permission to all Programs in the Firewall?

    The Server work fine, but i have problems with the Firewall settings, it´s a strange Error!

    The Server is a Didicated Server, we host a few Games without problems OS is Windows Server2012 R2 with all updates incl. the latest Netframework

    The Problem is the Firewall, i can give free the ports 2999-3001 but show offline!
    i say in the Rules all Ports on UDP, TCP but the Server show offline!
    Set the Programs ECO-Server.exe and Server Watcher, not work, too.
    but when i say in the rules all programs on Ports 2999-3001, i can see the Server, but i don´t want to give access to every program on incoming Rules.

    someone a Idea?


  • 6
    Posts
    1827
    Views
    Log in to reply


  • By default you should only need to open ports 3000 and 3001 for TCP (both incoming and outgoing). If you are behind a NAT, you will also likely need to forward those ports on your router.



  • Thanks for the answer, but this is my Problem, with my Server it´s not working, how i wrote:

    I can give the permission on ecoserver.exe but the server is shown Offline in the list!

    The only way to get access to the Server is turning the Firewall off or make a new incoming permission with the setting "any program", but this way it´s near like turn off the Firewall.

    Seams like the Client don´t get conection for the Server list, example:

    I give the Ports free and the Client say offline, then turn off the firewall and then push refresh on the Client the Server is Online in the Serverlist, but when i turn now the Firewall on without push refresh on the Client i can connect to the Server.



  • I keep getting invalid login tokens on my server. Any ideas



  • Below is from the server setup guide.
    If you entered a port range, try entering them manually.

    First of all Eco Server Default ports are:
    2999 for the policy server
    3000 for the client
    3001 For The Web interface ( is used in voting for laws and so on )
    you can change the default ports under the network tab and then select the Config tab
    There is a new setting under network / config called Public server. You need to set this value to true if you want your alpha 4 ++ server shown in the server browser

    I am a silver tier backer, I am not an employee of StrangeLoop Games - Take what I say with a grain, I'm probably wrong.



  • This post is deleted!

6
Posts
1827
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!