Internet loss after server connection failure


  • Eco Version: 7.2.5
    OS Version: Windows 10 Pro 64-bit (10.0, build 16299)
    Router: Netgear
    Router Hardware Version: WNDR3700v4
    Router Firmware Version: V1.0.2.96
    Windows Firewall is On
    AntiVirus is Off

    Repro steps:

    1. Launch Eco
    2. Select "Join"
    3. Join a server that can't be successfully connected to. For example, a password-protected "nitrado.net Gameserver".
    4. After the connection fails, try to join another server, and continue doing this up to three times.

    Actual:
    By the 3rd attempt or earlier, the server list will be empty after returning from the failed connection attempt, and pressing refresh/stop has no effect. Additionally, alt-tabbing out of Eco to view my connection status indicator in the task-bar shows a connection problem, and other devices on the network also experience an interruption. I found this to be repeatable, with no interruptions occurring over the course of 2 days, except when attempting the repro steps above. I also noted a great deal of instability in the app itself. It would often hang indefinitely on a connection attempt, or crash after I returned to the main menu and attempted to quit.

    Expected:
    Definitely no internet interruptions, and the server list should remain stable through multiple connection attempts.


  • 2
    Posts
    119
    Views
    Log in to reply


  • Check out EcoIssues and you'll probably find exactly this bug as similar issus are posted multiple times. I know this behavior, too. Running on similar specs like yours.

    • ­ Ecoylent is people! Do not replace any meal with Ecoylent!

    EcoIssues at GitHub
    Eco Discord
    SLG support@strangeloopgames.com


2
Posts
119
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!