Game crash when opening servers list


  • Hello,;

    as the tittle said the game crashes when opening the servesr list.

    I haven't any crash message, i already checked my drivers and game folder via steam.

    Any advice ?

    Game version : 0.7.1.2


  • 13
    Posts
    2389
    Views
    Log in to reply


  • hello, i have the same problem.

    annyone got a solution?

    specs
    Running windows 10
    I7-6800k 3.40 Ghz
    32 Gb Ram
    MSI GeForce GTX 1080 GAMING X 8G



  • Same here just bought the game, when i click join game, the server list loads. Game crashes half a second after though.
    i have the - 1080 TI -
    since mrtwilight has similar graphics cards, maybe its a problem with that. though i couldn't see why.
    My guess is that its a permission or port problem.
    Anyone?



  • Having the same issue, re-installing and also verifying files on steam has not resolved. Single player works perfectly fine, but half the point of this game is to have an economy with other players. I however have an nvidia 970 so my card is not the same as those above.



  • I have noticed what may be causing the problem. On my home pc, the game crashes when I try to search for servers. However if the server browser bugs and does not start searching for servers then it will show the browser without crashing. Also when I play single player and hit the G key to open the web interface, it fails to connect. I have just tested ECO on my work laptop, while the game lags horribly on it, I can both search for and connect to servers, AND if I play single player and press G to open the web interface, it connects and loads. I tested this at work. Once I get home I will test with my laptop again to see if the same issue is still happening. If it is then that means it must be an issue with my internet connection (which I have been having problems with lately).



  • Further testing on my side, I can still join servers on my laptop while on my home network, however my Desktop still crashes, and I can open the graph web interface on the laptop but not on my desktop. I can't see anything from Bitdefender (both machines have it) saying that it is blocking anything. I have tried uninstalling the game, restarting my machine, installing and restarting again, and still nothing works. My Crash logs folder is still empty. Event viewer states the following for the crash:

    Faulting application name: Eco.exe, version: 2017.3.0.63597, time stamp: 0x5a2fec8e
    Faulting module name: ntdll.dll, version: 10.0.16299.248, time stamp: 0xeffc9126
    Exception code: 0xc0000374
    Fault offset: 0x00000000000f87bb
    Faulting process ID: 0x640
    Faulting application start time: 0x01d3b498cc2e2733
    Faulting application path: Z:\SteamLibrary\steamapps\common\Eco\Eco.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
    Report ID: fd01c371-b0fe-4895-8a23-a0f2d54783ee
    Faulting package full name:
    Faulting package-relative application ID:

    So it looks like ntdll.dll is the issue. Can any devs take a look and give us some suggestions?



  • I downloaded the ECO Server on steam, and ran it, it eventually asked for permission to run the network command shell (just like singleplayer always does when I launch it) and when I clicked yes I noticed that the server command window stated that it failed to start Webserver: Exception has been thrown by the target of an invocation. I assume this is all related. I have checked multiple times that port 3001 is open and on my router it is. I am wondering if my PC for whatever reason is blocking the port for some reason.



  • I can't test with multiple machines, i just hope that this gets fixed with the new patch that is scheduled for today.



  • Any developer seeing this?
    Its a big thing since cooperation is an intricate part of the game. I know its early access but basically not being able to play at all will cause me to return the game.



  • Hi,
    i had the same Problem. The Problem seems to be the Connection
    Found some workaround. If you deactivate your firewall its works fine. But i didnt recommend doing this.
    Maybe Whitelisting ECO in your firewall works.

    I am using Bitdefender



  • I also use Bitdefender on both my Laptop and Desktop, however even disabling my firewall and all protection on my desktop did not fix anything. It's been over 2 weeks since the original poster put this up and still no input from any of the dev team.



  • I have exactly the same problem and the same error in the event log. Tried reinstalling the game, updating wondows 10, search for damaged windows files, also tried to shut down all firewalls, nothing helps.
    The last thing that I didn't try is reinstalling windows but really ... that can't be the solution if everything else works absolutely fine and I'm not even sure that would work.
    So I spent about 5-6 hours trying to fix this issue more then I played the game, and I don't want to play single-player.

    edit: I actually found a workaround.
    I went into the steam folder and changed the compatibility mode for the eco.exe to Windows 7 and to run it as administrator and it works now. I can join servers and the server browser doesn't crash.
    After trying it is actually the compatibility part that worked, you don't need to run it as admin.



  • @rdgviolence said:

    edit: I actually found a workaround.
    I went into the steam folder and changed the compatibility mode for the eco.exe to Windows 7 and to run it as administrator and it works now. I can join servers and the server browser doesn't crash.
    After trying it is actually the compatibility part that worked, you don't need to run it as admin.

    Can confirm that this works, however when I set it to only compatibility for Windows 7 it still failed, whereas then setting it to run as Administrator, works 100% now. Thanks very much rdgviolence for the work around!


13
Posts
2389
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!