[Bug] Construction menu unable to recognize correction of initially improper foundation material?


  • I had some trouble completing a mill that I was trying to build, and after troublshooting for a while I realized that I'd made the foundation out of the wrong material (regular stone rather than refined stone, although I had the required quantity of refined stone in the upper levels). It may be a minor bug in itself that the interface gave no initial indication of this issue (the construction window progressed from showing my progress towards area enclosed to showing the full details of height, volume, etc. once I'd laid out the foundation in unrefined stone, just as if I'd been using the right material), but perhaps more significant was that once I corrected this issue by replacing the foundation with refined stone, it still wouldn't let me complete the construction. I eventually canceled the construction and started a new one with the same corners at the original site, and it then instantly recognized the building as a complete mill and let me complete the construction right away; so there was nothing wrong with the building, just with the game's recognition of its completion.

    So, in short, it seems that if a building is started with a foundation of the wrong material, the game is unable to recognize if you later correct the issue, rendering the construction impossible to complete unless you cancel it and start a new one. I haven't tried to replicate this, admittedly.


  • 3
    Posts
    868
    Views
    Log in to reply




  • Issue was closed without comment.

    I am a Wolf-Tier backer and a Volunteer on the forums helping out with Bug reports, Support and Moderation. I am not a StrangeLoopGames Employee / Developer.

    I am the founder of DBM Hosting. High quality server hosting.


3
Posts
868
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!