{SERVER} Crash on world load after 2 days of running fine.


  • Woke up today and started my server. Everything had been running fine and even ran well after the server hotfix application last night. Today this is what I keep getting. Any ideas? I haven't changed anything :/ .Untitled.png


  • 17
    Posts
    3841
    Views
    Log in to reply


  • Sorry to hear =( .. you should have a crash dump in your server folder somewhere .. you can send this one directly to nfuller@strangeloopgames.com and this screen .. he can then look what the issue might be and fix it



  • Sent both. Hopefully he can figure it out. Thank you for the heads up.



  • Let me venture a guess.
    You tried to move around pollution?
    @NoBlackThunder This looks very much like my crash.



  • possible =) every report is welcome =) that means more bug data, and that means its easier to find the cause of an issue



  • I haven't had any pollution to move yet.



  • @Hed9870
    Do you remember?
    When you last shut down the server before starting it back up.
    Did you have any weird issues, like blocks that you are placing/breaking not (dis)appearing?



  • No problems like that. I had just finished building my refinery and logged off. There was an issue of all the metallic graphics for tools being black.



  • Same basic situation here: was running fine yesterday, woke up this morning to it having crashed and couldn't reload. I've tried multiple times and restarted the computer, but no change. I'm including the two dump files that I found; maybe those will help?

    Untitled.png

    [08:06 Eco.Plugin] Initializing ModKitPlugin...
    [08:06 Eco.ModKit] Mods recompiling...
    [08:07 Eco.ModKit] Mods recompiled without error.
    [08:07 Server] Initializing ModKitPlugin finished in 946 ms
    [08:07 Eco.Plugin] Initializing Serialization...
    [08:23 Eco.Plugin] Serialization version hash: D2682A29
    [08:23 Server] Initializing Serialization finished in 16061 ms
    [08:23 Eco.Plugin] Initializing StorageManager...
    [08:23 Server] Initializing StorageManager finished in 0 ms
    [08:23 Eco.Plugin] Initializing WorldGeneratorPlugin...
    [08:24 Server] Initializing WorldGeneratorPlugin finished in 316 ms
    [08:24 Eco.Plugin] Initializing NetworkManager...
    [08:24 Server] Initializing NetworkManager finished in 5 ms
    [08:24 Eco.Plugin] Initializing WorldCore...
    [08:24 Eco.Plugin] Loading world...
    [08:28 Eco.Plugin] Loading world finished in 3477 ms
    [08:28 Server] Initializing WorldCore finished in 4324 ms
    [08:28 Eco.Plugin] Initializing EcoSim...
    [08:28 Eco.Plugin] Loading time...
    [08:28 Eco.Plugin] Loading time finished in 3 ms
    [08:28 Server] Initializing EcoSim finished in 245 ms
    [08:28 Eco.Plugin] Initializing SimStats...
    [08:28 Eco.Plugin] Loading animals...
    [08:29 Eco.Plugin] Loading stats...
    [08:29 Eco.Plugin] Loading stats finished in 31 ms
    [08:29 Server] Initializing SimStats finished in 218 ms
    [08:29 Eco.Plugin] Initializing Legislation...
    [08:29 Eco.Plugin] Loading animals finished in 144 ms
    [08:37 Server] Initializing Legislation finished in 8150 ms
    [08:37 Eco.Plugin] Initializing ChatServer...
    [08:37 Server] Initializing ChatServer finished in 0 ms
    [08:37 Eco.Plugin] Initializing ControllerPlugin...
    [08:37 Server] Initializing ControllerPlugin finished in 0 ms
    [08:37 Eco.Plugin] Initializing UserManager...
    [08:44 Eco.Plugin] Loading users...
    [08:44 Eco.Plugin] Loading users finished in 15 ms
    [08:44 Server] Initializing UserManager finished in 6942 ms
    [08:44 Eco.Plugin] Initializing WorldObjectManager...
    [08:54 Eco.Plugin] Loading worldobjects...
    [08:56 Eco.Plugin] Loading worldobjects finished in 1918 ms
    [08:56 Eco.Plugin] 4 Error(s) occurred when loading worldobjects:
    Object reference not set to an instance of an object.
    Object reference not set to an instance of an object.
    Exception has been thrown by the target of an invocation.
    Exception has been thrown by the target of an invocation.

    [08:56 Eco.Gameplay] Errors loading world objects.

    Unhandled Exception: System.Reflection.TargetInvocationException: Exception has
    been thrown by the target of an invocation. ---> System.NullReferenceException:
    Object reference not set to an instance of an object.
    at Eco.Gameplay.Objects.Manager.WorldObjectManager..ctor()
    --- End of inner exception stack trace ---
    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOn
    ly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Bo
    olean& bNeedSecurityCheck)
    at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipChec
    kThis, Boolean fillCache, StackCrawlMark& stackMark)
    at System.Activator.CreateInstanceT
    at Eco.Server.Plugins.PluginManager.AddPluginT
    at Eco.Server.Plugins.PluginManager..ctor()
    at Eco.Server.MainClass.Main(String[] args)

    11282913.ecodmp 11280856.ecodmp



  • Ok, that's strange--now it just loaded, but still threw errors (see below). Maybe I'm ok now...?

    [18:48 Eco.Plugin] Initializing WorldObjectManager...
    [19:01 Eco.Plugin] Loading worldobjects...**
    [19:04 Eco.Plugin] Loading worldobjects finished in 3065 ms
    [19:04 Eco.Plugin] 2 Error(s) occurred when loading worldobjects:
    Exception has been thrown by the target of an invocation.
    Exception has been thrown by the target of an invocation.

    [19:04 Eco.Gameplay] Errors loading world objects.
    [19:04 Server] Initializing WorldObjectManager finished in 16083 ms
    [19:04 Eco.Plugin] Initializing WebServerPlugin...
    [19:05 Server] Initializing WebServerPlugin finished in 577 ms
    [19:05 Eco.Plugin] Initializing DisasterPlugin...
    [19:05 Server] Initializing DisasterPlugin finished in 0 ms



  • are you shutting down the server? and restarting it the next day when this happens? if yes how to you shut it down ?



  • @NoBlackThunder , if you're asking me: I don't see any options for properly shutting down the server, so I'm just closing the application. When the crash happened, I had not yet closed the server--it was in the middle of the night.

    I restarted the server again, looks like a different error. Strange that I'm not getting the same error each time...

    [26:11 Eco.Plugin] Loading worldobjects finished in 496 ms
    [26:11 Server] Initializing WorldObjectManager finished in 10715 ms
    [26:11 Eco.Plugin] Initializing WebServerPlugin...
    Failed to start WebServerPlugin; did you set your permissions?
    at System.Net.HttpListener.AddAllPrefixes()
    at System.Net.HttpListener.Start()
    at Microsoft.Owin.Host.HttpListener.OwinHttpListener.Start(HttpListener liste
    ner, Func2 appFunc, IList1 addresses, IDictionary2 capabilities, Func2 logge
    rFactory)
    at Microsoft.Owin.Host.HttpListener.OwinServerFactory.Create(Func2 app, IDic tionary2 properties)
    Access is denied
    [26:11 Server] Initializing WebServerPlugin finished in 249 ms
    [26:11 Eco.Plugin] Initializing DisasterPlugin...
    [26:11 Server] Initializing DisasterPlugin finished in 0 ms



  • ahh ok. just asking=)



  • So.... I'm assuming that I altered something in the settings that I should have left alone... My server keeps crashing every time that I try to run it now. The read-out I get from the server is below. Each time the message is the same. In creating a new installation, I do not have problems loading the game now.

    I'm attaching the dump reports as well--hopefully they will have more useful info for y'all to understand. Please let me know what other specifics you'd like for me to provide and I'll do what I can. If it'd help, I can zip the folder directory and send you the whole thing.

    11295938.ecodmp 11295859.ecodmp 11295845.ecodmp 11295733.ecodmp 11295646.ecodmp 11290159.ecodmp 11290029.ecodmp 11282913.ecodmp 11280856.ecodmp

    [58:36 Eco.Plugin] Initializing ModKitPlugin...
    [58:36 Eco.ModKit] Mods recompiling...
    [58:37 Eco.ModKit] Mods recompiled without error.
    [58:37 Server] Initializing ModKitPlugin finished in 658 ms
    [58:37 Eco.Plugin] Initializing Serialization...
    [58:54 Eco.Plugin] Serialization version hash: D2682A29
    [58:54 Server] Initializing Serialization finished in 16989 ms
    [58:54 Eco.Plugin] Initializing StorageManager...
    [58:54 Server] Initializing StorageManager finished in 0 ms
    [58:54 Eco.Plugin] Initializing WorldGeneratorPlugin...
    [58:54 Server] Initializing WorldGeneratorPlugin finished in 322 ms
    [58:54 Eco.Plugin] Initializing NetworkManager...
    [58:54 Server] Initializing NetworkManager finished in 5 ms
    [58:54 Eco.Plugin] Initializing WorldCore...
    [58:55 Eco.Plugin] Loading world...
    [58:59 Eco.Plugin] Loading world finished in 3894 ms
    [58:59 Server] Initializing WorldCore finished in 5027 ms
    [58:59 Eco.Plugin] Initializing EcoSim...

    Unhandled Exception: System.AggregateException: One or more errors occurred. ---

    System.NullReferenceException: Object reference not set to an instance of an o
    bject.
    at Eco.Simulation.Agents.Blocks.PlantBlock.Tick(IAwakener awakener)
    at Eco.Shared.Utils.ListExtensions.ForEach[T](IEnumerable1 enumeration, Acti on1 action)
    at Eco.World.PersistentChunk.Tick()
    at System.Threading.Tasks.Parallel.<>c__DisplayClass272.<PartitionerForEachW orker>b__29() at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask) at System.Threading.Tasks.Task.<>c__DisplayClass0.<ExecuteSelfReplicating>b__ 1(Object ) --- End of inner exception stack trace --- at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceled Exceptions) at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationTo ken cancellationToken) at System.Threading.Tasks.Parallel.PartitionerForEachWorker[TSource,TLocal](P artitioner1 source, ParallelOptions parallelOptions, Action1 simpleBody, Actio n2 bodyWithState, Action3 bodyWithStateAndIndex, Func4 bodyWithStateAndLocal,
    Func5 bodyWithEverything, Func1 localInit, Action1 localFinally) at System.Threading.Tasks.Parallel.ForEachWorker[TSource,TLocal](IEnumerable
    1 source, ParallelOptions parallelOptions, Action1 body, Action2 bodyWithState
    , Action3 bodyWithStateAndIndex, Func4 bodyWithStateAndLocal, Func5 bodyWithE verything, Func1 localInit, Action1 localFinally) at System.Threading.Tasks.Parallel.ForEach[TSource](IEnumerable1 source, Act
    ion`1 body)
    at Eco.World.WorldCore.Run()
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionCo
    ntext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, C
    ontextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, C
    ontextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart(Object obj)



  • normaly nfuller likes to get all crashdumps to his mail .. but i guess i have to gather all of them and forward that to him =P



  • @NoBlackThunder So, would you like me to send you anything else or is what I've attached sufficient?



  • no for now i think this is ok


17
Posts
3841
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!