Poor FPS


  • I have a very good PC. Let me just get that out of the way.. I7-3770K processor... GTX 970 Super-Clocked 4GB GPU... 16GB DDR5 RAM... but this game just plays very poorly. I understand its in alpha still but I've seen many youtube videos with guys playing on high settings and the FPS is in the 40s. I don't understand how this game could be struggling with FPS when I can play games like GTA V on Ultra settings.

    I've toned down the graphics in game and can manage to get into the 30s but I want the game to look beautiful like it does for a lot of other gamers' videos on Youtube.


  • 14
    Posts
    1598
    Views
    Log in to reply


  • @Robmeister89 I'm in the same boat. i7-7700K processor 4.2GHz 64gb DDR4 RAM, GeForce GTX 1080 Ti, all liquid cooled. I got the specs beat for what this game should need by a mile, and everything else I run, runs perfectly at maximum settings, yet Eco is (I'm sad to say) running like a dog. Low framerates, even with numerous options turned down (as much as I can tolerate anyway).

    I can barely manage 20FPS.

    Edit: Oops. Corrected typo.



  • There's no such thing as DDR5 RAM (gddr5 is a thing though)... unless ur from the future, its planned to be released 2018... the I7 3770k is a good processor but is last gen tech, still should be good enough. Just remember, though, this game is still in Alpha, 0.5.6, so not optimized for all computer setups...

    Im running I7-7700K, 16 gb DDR4 @2777mhz, GTX 1080, M.2 480gig ssd (running at 2.8k iops) and im getting ~50-60 frames... This leads me to believe something on ur rig is the problem. besides checking running applications and waiting for optimization patches, I can't think of any suggestions



  • For all you know, I am from the future :P

    Seriously, though, it is DDR3. Still, though, I can play most games on Ultra settings or at a minimum High. But this game? Its not graphically demanding. Its clearly just an issue with the game itself being in alpha and not optimized for my system.



  • @Robmeister89

    im with ya mate, top of the line comp. crap FPS so i have to drop view range down and some rendering to get 40+fps

    Server Name: [US] Mediocre At Best [30day Meteor]
    IP: 198.46.227.194
    Discord: https://discord.gg/usSRE2G
    "Come trade, build, grow as you please!"
    Enjoy our custom mods!



  • I've corrected my typo. Sadly, I am not from the future either, but my PC is as close as it can get to being that, and runs quite literally a 100+ game Steam library all at maxed out settings, except for Eco, where I've got to turn many things way way down to get even a mediocre FPS.



  • @cr0ss0vr said:

    There's no such thing as DDR5 RAM (gddr5 is a thing though)... unless ur from the future, its planned to be released 2018... the I7 3770k is a good processor but is last gen tech, still should be good enough. Just remember, though, this game is still in Alpha, 0.5.6, so not optimized for all computer setups...

    Im running I7-7700K, 16 gb DDR4 @2777mhz, GTX 1080, M.2 480gig ssd (running at 2.8k iops) and im getting ~50-60 frames... This leads me to believe something on ur rig is the problem. besides checking running applications and waiting for optimization patches, I can't think of any suggestions

    I tend not to put games on my SSD, but your setups and mine are very similar, so I'll try moving Eco to the SSD and see if that makes any difference. Hopefully I can find something because the game is starting to get unplayable the more I advance through it, and despite turning settings down (which, on the basis of my PC's specs I should NOT need to do), my frame rate is now sub 20.

    Also, I don't think it can be an issue of there being "other things running" etc, since every other game I've got runs perfectly (for example, one amongst many I could site, I play ARK Survival at absolutely max settings with 60+ FPS).



  • @cr0ss0vr said:

    There's no such thing as DDR5 RAM (gddr5 is a thing though)... unless ur from the future, its planned to be released 2018... the I7 3770k is a good processor but is last gen tech, still should be good enough. Just remember, though, this game is still in Alpha, 0.5.6, so not optimized for all computer setups...

    Im running I7-7700K, 16 gb DDR4 @2777mhz, GTX 1080, M.2 480gig ssd (running at 2.8k iops) and im getting ~50-60 frames... This leads me to believe something on ur rig is the problem. besides checking running applications and waiting for optimization patches, I can't think of any suggestions

    Ok, I moved ECO to the SSD, bugger all difference really (a little faster perhaps, but not by much).

    Could you please detail what settings you're running at while getting these 50-60 FPS?



  • running it in a maximized window, hence the screenshot has the title bar... but yeah, my game is on my ssd

    Settings
    Adv. Settings <- will be turning vsync off when i get home from work



  • @cr0ss0vr said:

    running it in a maximized window, hence the screenshot has the title bar... but yeah, my game is on my ssd

    Settings
    Adv. Settings <- will be turning vsync off when i get home from work

    Well, I matched your settings. As you can see, I got a VERY different result.

    Notevenclose.jpg

    Oddly, despite what the menu there is saying, the game does seem to be running more smoothly since putting it into Maximized Window state.

    Also, your Render Scale is different to mine.



  • rather strange with the render scale...

    what's ur RAM clocking at? if it is slower it may have an effect... mine is at 2777mhz
    how big is the map ur on? map size will probably effect things like current animal spawns and amount of blocks to keep in RAM etc. (i have no idea what size im on, but its rather small, walkable in around 5-7 mins

    dont forget this is still alpha 0.5.1, remember ARK back then? also around 15 fps, but it did have more foliage and stuff...
    i also love how the image is named "notevenclose" :P



  • @cr0ss0vr said:

    rather strange with the render scale...

    what's ur RAM clocking at? if it is slower it may have an effect... mine is at 2777mhz
    how big is the map ur on? map size will probably effect things like current animal spawns and amount of blocks to keep in RAM etc. (i have no idea what size im on, but its rather small, walkable in around 5-7 mins

    dont forget this is still alpha 0.5.1, remember ARK back then? also around 15 fps, but it did have more foliage and stuff...
    i also love how the image is named "notevenclose" :P

    Google "Australia State of Origin", that'll explain why I can't get back into the game tonight to give you an update on the RAM load (speed is 2777mhz also but I didn't check load through last playthrough). My CPU is running at 4.2ghz base, with it overclocked to 4.8ghz, though I've got that temporarily removed to see if it was making any difference to ECO. Our video cards are identical (except mine is the liquid cooled variant) so that can't be it.

    I do remember ARK back then, so, being fully cognizant of the early state of the game (particularly when I look through some of the extreeeeeemeelly sparse gamepedia wiki entries on various topics), so hopefully I'm not sounding to huffy. As my IRL friends and I often say on some of the games we run, it's all "The Joys Of Alpha".

    The Map is 200x200, though I was having the same FPS issues on the first 100x100 map I had (which I abandoned due to another bug).

    And yeah, couldn't resist the file name... hehe.

    As I say, despite the menu saying it's still choking on 15 FPS, the game itself appears to be running much smoother, but I won't be able to say for sure until after the Mighty Mighty Blues have pasted those nasty Queensland Maroons all over the park tonight!!!

    Will post tomorrow with a longer play test of these new settings.



  • im on the non-staging version of the game too, if that makes any difference... Any results?



  • @cr0ss0vr said:

    im on the non-staging version of the game too, if that makes any difference... Any results?

    Yes, unfortunately all bad.

    I've been able to get close to 60 FPS (got to about 45 FPS), but only by REALLLY aggressively toning down just about all the graphics options.

    How would I switch to the non-staging version of the game? (Given that I have only a single download link from the website).


14
Posts
1598
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!