No Vsync option = 100% GPU load


  • Server, Client or Website?

    Client

    OS/Web Browser?

    Windows 10 Home 64-bit (10.0, Build 14393) (14393.rs1_release.170602-2252)
    GPU NVIDIA GTX 970

    Detailed Description of Issue:

    It seems like there's no option to enforce Vsync (or any other kind of FPS limiter) in the client. I tried to enforce Vsync via the NVIDIA control center, but the client is just ignoring these settings.

    Without Vsync, the FPS in the game is very high (400+ in my case, on the lowest settings), which means, GPU load is 100% all the time, leading to very high GPU temperatures with potential risk of damaging hardware permanently. Not to mention screaming vents.

    Reproducible? How difficult is it to reproduce?

    Yes, easily reproducible.

    Steps to reproduce bug/issue:

    1. Enforce settings in NVIDIA control centre for the eco.exe (VSYNC = On)
    2. Start client
    3. Watch client ignoring the settings (high FPS in the ESC menu + monitor GPU sensors in GPU-Z or any other tool)
    4. Stop the client.
    5. Watch the GPU load and other sensors immediately falling back to 0%

    Additional Comments:

    Uploaded screenshots and dxdiag.txt
    https://drive.google.com/file/d/0B30XqdKJJS7SbHhwVU5LZUwzd1U/view?usp=sharing

    I'll provide more info if needed.

    Client Version? [Alpha .01 for example]

    Alpha 0.5.6


  • gpu load 2 vsync 2 fps 1
    1
    Posts
    588
    Views
    Log in to reply

Internal error.

Oops! Looks like something went wrong!