Eco Server list and multiple servers


  • Can you have multiple server instances running from a single IP (different ports) and have them show up in the server list?

    For example, I load my server files into stupid fast storage (faster than SSD) then launch two or more instances, and only one instance shows up in the server list. I have set different port numbers as well as different description, but only the most recent launch shows up.

    Server has 126GB of ram and I would like to use it for more than one server if possible.


  • server 83 server list 9 hosting 3
    9
    Posts
    3453
    Views
    Log in to reply


  • Yes you can have multiple servers running on a single IP using different ports (they will need 4 ports assigned). To do this, however you will need to run software for handling multiple instances and separate configurations - something like TCADMIN.

    Pam
    Community Moderator
    Discord: Pam#5439
    reddit moderator: rentechd
    https://discord.gg/Mg4WJe9



  • @rentechd said:

    (they will need 4 ports assigned)

    OK I understand the two ports, say, 3000 and 3001. What are the other two? I assume these are related to server discovery?
    Or are you referring to the fact that each instance requires 2 ports?

    I am using a unique approach to server setup. The server configs are managed by my own software and all storage is loaded into memory. Basically a RAM Disk sort of approach with some other special sauce.

    The network configuration gets set on deployment and a port between 30000 and 40000 is assigned to the instance. The appropriate ports are also added to the firewall.



  • @thepenguinmaster
    This is a intresting question you have here, so intresting i did a few test also.
    to see what you exactly mean with, and yes this is a litle bump on the road.

    Im not 100% sure why its not working as im no pro on networking, but i think the problem is the following, from my seting.

    Server 1:
    Gameserverport: 3000 tcp
    webserverport: 3001 tco
    Port X: 2999 udp

    Server 2:
    Gameserverport: 3002 tcp
    webserverport: 3003 tcp
    Port X: not active.

    I think that for a server to show up on the eco public server list, udp port 2999 is used. as there are no config options to change this port (at least from what i can find), the problem is that server 2 in my test setting could not send a signal to the public server list service, as udp port 2999 was already in use by server 1.

    Would be nice if this was made configurable in the future, for now a work around has to be found i geus. i dont know if its possible but if there are programs that can intercept network traffic from a program in this case server2.eco and redirect to to example port 2998 it would be a work around solution.

    Talk, Play, Laugh, Teach, Learn.



  • We assign 10 ports per server - Gameport, webport, query port and custom port (telnet/rCon)) and then the other 6 are left unused to space out the ports. We also use software that manages the servers separately under .Net so there is no conflict between instances we don't assign a UDP port
    The majority of users that run multiple instances on servers are dedicated hosting providers and we are not having a problem with the configuration of the game with what is already made configurable. I can run as many instances as I want on a server.

    Pam
    Community Moderator
    Discord: Pam#5439
    reddit moderator: rentechd
    https://discord.gg/Mg4WJe9



  • So rentechd are you saying that you do not run into this problem and that multiple instances of the server running on one machine will appear in the server list without additional configuration?

    Zaskersky thanks for testing this out. Not sure what others are doing differently, but it is good to hear that I am not the only one seeing this.

    Also this is with a windows host machine.



  • @thepenguinmaster sorry I don't mean to quote but @rentechd said this
    "We also use software that manages the servers separately under .Net so there is no conflict between instances"



  • I see. With the lack of punctuation, it was difficult to interpret. I assume they are using a modified version of the server then.
    I am managing server settings externally as well, but unless you have access to the source code, you cannot set the other ports. I will attempt to space out ports and see if that changes my results.

    I am also curious how others manage the memory leaks?



  • We are not using a modified version of the server. Each instance of the server is installed as if it was installed on a separate piece of hardware. The only difference between server1, server2, server3,.... server33, server34 and so on is the port range assigned to the server. You can see all of our servers in the server list that are configured as public. Those that are not configured as public can still all be seen in the game browser if they are set as 'favorites' after being added via 'add server'.

    There is still a bit of a bug where you have to sometimes refresh the in game browser several times to see a server in the list - and this is not because servers are on the same hardware. There are people that have to refresh their list 3-5 times to see their own server that resides at their house and only runs one instance but make sure that bug is not confusing your issue.

    Are you able to see the server/connect to the server manually once its up and running even if its not view-able in the in-game browser?

    As for memory leaks, they have not been that much of an issue on the server. the bad one is the one on the client and that we leave up to the individual player. As for the server we just have a scheduled task that the server admin for that instance sets up restart the server instance daily and that seems to solve the issue. Of course, they can recycle that instance anytime they wish. If we notice that there appears to be a situation where the leaked memory is not being returned to the memory pool after a restart if a server instance we will monitor it and perform a restart of the hardware to flush the memory if needed. this was only required one time since we started running ECO GS

    Pam
    Community Moderator
    Discord: Pam#5439
    reddit moderator: rentechd
    https://discord.gg/Mg4WJe9


server 83 server list 9 hosting 3
9
Posts
3453
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!