Steplife Server, Staging alpha 5.5 #516ceabd - Bug List


  • New staging build seems to be stable on our server, so compiling a new list of bugs issues here.

    1. Calorie efficiency tooltip has a code typo. says sprite-"ui_elements" name-"ui_arrowimage" color #ffffff> Calorie Efficiency. Looks like the < is missing in front of Sprite.

    2. Crafting efficiency seems to be completely broken again, getting no material cost or time reduction applied to crafting items.

    3. Tailoring table still reports 9 crafting tables in the room (only objects in room are 3x chest, quarry, tailoring table)

    4. Pipes (both copper and iron) can be placed in toolbar/backpack even though they say carried only. Hammering them puts them into carry slot, however they can be dragged to the toolbar or backpack afterwards.

    5. Clicking Economy Viewer crashes the client 100% of the time. (With an admittedly small test pool of 5 attempts. All 5 crashed the client to desktop). No dump file, no error messages.

    6. Mint is still broken. Picking up an existing mint and placing it back down wipes out the ability to mint that currency anymore. If you use the same currency name a 'new' currency with the same name is created.

    7. Multiple items missing from the store selector (and the search&select command, since they use the same interface). Some items include: axe, pickaxe, shovel, scythe, hammer, paper, iron/copper/gold ingots.

    8. Food tooltips within a cooking station do not display any stats (carbs/fats/calories/etc.) Food in your inventory does, however.


  • 3
    Posts
    829
    Views
    Log in to reply


  • When crafting, 1 second in game is 10 seconds real time.. Is this a bug or something i messed up in server files?



  • our 5.5 server crashes with error:
    --BEGIN DUMP--
    Dump Time
    03/09/2017 17:12:06

    Exception
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Eco.WorldLayerSystem.AnimalLayer.DamageAnimals(Vector2i layerPos, Single maxDamage)
    at Eco.WorldLayerSystem.AnimalLayer.Push(Vector2i layerPos)
    at Eco.WorldLayerSystem.AnimalLayer.Push()
    at Eco.Shared.Utils.EnumerableExtensions.ForEach[T](IEnumerable1 enumeration, Action1 action)
    at Eco.Simulation.ExternalInputs.WorldLayerSync.<>c__DisplayClass15_0.<Tick>b__8()
    at Eco.Core.Plugins.TickTimeUtil.TimeSubprocess(Action func)
    at Eco.Simulation.ExternalInputs.WorldLayerSync.Tick(WorldInteraction interactions, LayerTypes layers)
    at Eco.Core.Plugins.TickTimeUtil.TimeSubprocess(Action func)
    at Eco.WorldLayerSystem.WorldLayerSimulation.ForceTick(Boolean worldInteraction)
    at Eco.WorldLayerSystem.WorldLayerSimulation.TryTick(Double time)
    at Eco.WorldLayerSystem.WorldLayerSimulation.Run()
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart(Object obj)

    --END DUMP--


3
Posts
829
Views
Log in to reply

Internal error.

Oops! Looks like something went wrong!